browser should not keep the zoom factor when navigating

RESOLVED DUPLICATE of bug 868047

Status

()

RESOLVED DUPLICATE of bug 868047
6 years ago
5 years ago

People

(Reporter: julienw, Assigned: nical)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(b2g18+)

Details

(Reporter)

Description

6 years ago
STR:
* go to http://everlong.org/mozilla/testcase-zoom/
* zoom in, then click on link

Expected:
* the target website has zoom = 1

Actual:
* the zoom factor was kept when navigating

Please note that the target website has a meta viewport and some media queries, so it is actually adapted to work on mobile browsers. In this case we should definitely reset the zoom factor. However I'm not sure when we're navigating to a website that does not have a meta viewport command.

In Firefox/Android we always reset the zoom factor, even when going back to a previous page, which might be wrong (imho we should use the zoom factor we had previously in this page, but that could be another bug).
(Reporter)

Comment 1

6 years ago
First link goes to a mobile-adapted website, second line goes to a non-mobile-adapted website. So you can see both behaviours.
Assignee: nobody → ben
blocking-b2g: tef? → -
tracking-b2g18: --- → +
Just to note, firefox/android had this issue in 4.0 and was fixed later on.
I don't think we can fix this on the Gaia side.
Assignee: ben → nobody
Component: Gaia::Browser → General
QA Contact: nhirata.bugzilla
We're supposed to be resetting the zoom.
Component: General → Graphics: Layers
Product: Boot2Gecko → Core
Let's do this once we land layers refactoring.
Assignee: nobody → nical.bugzilla
(Reporter)

Comment 6

6 years ago
FTR this is one of PPK's grief on FxOS : https://twitter.com/ppk/status/383169960945930240
(Reporter)

Updated

6 years ago
blocking-b2g: - → 1.3?
Is this a dupe of bug 868047 or are they separate issues?
Julien retested with bug 868047 and this appears to be fixed.  Marking as dupe.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 868047
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.