Proxy Auto Config Script Performance - Firefox 18

RESOLVED WORKSFORME

Status

()

Core
Networking
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: jdrosa, Unassigned)

Tracking

({regression})

18 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-backlog])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 701777 [details]
Instrumented PAC

After the automatic upgrade from Firefox 17 to 18, Proxy Auto Config (PAC) script performance has been negatively impacted.

Within the PAC script, the myIpAddress() method is being called and at times it takes approximately 1000ms in order for the myIpAddress() method to return.

On a web page where the PAC script is parsed often, this can lead to very long page load times.

Performance of the PAC was tested against FF 17, where the myIpAddress() method returned in less than 20ms (typically), and Aurora, where the average time to run myIpAddress() is better than FF 18, though there are still occasions where the method takes roughly 1000ms to return.

The PAC was instrumented and monitored using the built in FF Error Console. The PAC is attached for reference.

This is a follow on to bug 829646.
Component: General → Networking
Keywords: regression
Product: Firefox → Core

Comment 1

5 years ago
I can confirm this bug in Firefox 20.0.1 on Windows 7 x64. I can also confirm that in FF 17 the error did not exist. I reproduced the bug on 5 different PCs.

As soon as myIpAddress() is used in the PAC script page loading times increase significantly ( up to 10 times depending on the web site ). It makes no difference whether myIpAddress() is called inside or outside of FindProxyForURL().

On the Linux version (20.0 on Ubuntu x64) I cannot reproduce the error.
Whiteboard: [necko-backlog]
Hi reporter,

Can you please provide a functional test case so I can test this issue on my end? Also, please provide more information on how to use your attachment script in order to reproduce this.

Is this still reproducible on your end ? If yes, can you please retest this using latest FF release and latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).

Thanks,
Paul.
Flags: needinfo?(jdrosa)
(Reporter)

Comment 3

2 years ago
I believe this bug can be closed. I have not traced back to find out which FF release addressed this issue, but the slowness of the myIpAddress() method is no longer evident in the FF 44.0.2.

If you are still interested in looking further, the method to reproduce the issue is to configure FF to use the attached proxy auto-config file and monitor FF as it uses the myIpAddress() method. It's been quite a while since I submitted this bug, so I would have to dig deep in order to recall how I tested the script to determine the amount of time the method consumed. The issue was killing my browser performance within my corporate network environment because the proxy config script was making many calls to the method. For a while I maintained my own PAC that reduced the number of calls to the method to 1, which helped tremendously. However, the issue appears to now be resolved.
Flags: needinfo?(jdrosa)
Based on comment 3 from the reporter, changing status to RESOLVED WORKS FOR ME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.