[Facebook import][FTE] Selection/Deselection of Facebook contacts should close after the import is finished.

VERIFIED FIXED

Status

Firefox OS
Gaia::First Time Experience
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: nhirata, Assigned: michalbe)

Tracking

unspecified
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.0 fixed)

Details

(Whiteboard: [Triaged:1/17])

Attachments

(1 attachment, 1 obsolete attachment)

## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/8f2ef4998b60
Gaia   df38c1bb813029f3ccfa4a997fb1529b3ff1a1ff
BuildID 20130111230201
Version 18.0
Otoro
  
## Repro :
1. run the FTE, get to the import contact option
2. select import from facebook
3. sign in
4. select all friends and import

## Expected :
once the import is done, it should exit the screen

## Actual :
the selection screen is still up; you have to hit the x in order to exit.

## Note :
1. for FTE, it leaves the user in wondering what to do next.  Bad FTE for importing facebook contacts
blocking-b2g: tef? → tef+
(Assignee)

Updated

5 years ago
Assignee: nobody → mbudzynski
(Assignee)

Comment 1

5 years ago
Created attachment 702339 [details]
patch
Attachment #702339 - Flags: review?(francisco.jordano)
Comment on attachment 702339 [details]
patch

Jose Manuel will do this review. He is in charge of keeping integration of FB sync  in both places, ftu and contacts.

Thanks!
Attachment #702339 - Flags: review?(francisco.jordano) → review?(jmcanterafonseca)
(Assignee)

Comment 3

5 years ago
Ok, thanks!

Updated

5 years ago
Blocks: 831026
Can we get more info here on what state this leaves the user in?  If there is no way to tell that the import completed and there are still steps to complete in the FTE process then this is more likely to be a tef+.
blocking-b2g: tef+ → tef?
Keywords: qawanted
blocking-b2g: tef? → tef+
tracking-b2g18: ? → ---
The state is still on the selection of Facebook Friends page.  It will end up confusing the user esp on a first time experience.
Keywords: qawanted
Whiteboard: [EU_TPE_TRIAGED]

Updated

5 years ago
Blocks: 831222

Updated

5 years ago
Attachment #702339 - Flags: review?(jmcanterafonseca) → review-

Comment 8

5 years ago
Created attachment 703221 [details]
Patch that includes the banner, refactors and removes unnecessary code
Attachment #702339 - Attachment is obsolete: true
Attachment #703221 - Flags: review?(fernando.campo)
Attachment #703221 - Flags: review?(crdlc)
Whiteboard: [EU_TPE_TRIAGED] → [Triaged:1/17]
Comment on attachment 703221 [details]
Patch that includes the banner, refactors and removes unnecessary code

Tested and working like a charm. Thanks Jose
Attachment #703221 - Flags: review?(fernando.campo) → review+
Fernando, did you test in contacts as well? thanks
No, sorry I didn't, only on FTU. Gime some minutes and I'll do ;)
Ok, tested in contacts, works well too. Just one weird thing. If I import contacts from fb during FTU, later I'm not able to update or remove them from Contacts settings (the facebook setting is disabled). 
Is this the expected behaviour?
Should I file a new bug?
Flags: needinfo?(jmcf)
After talking with Jose Manuel and perform some more tests to nail it down, decided the error would be probably caused by lost connection, not by malfunction of the app, so forget my previous comment :D
Flags: needinfo?(jmcf)
Comment on attachment 703221 [details]
Patch that includes the banner, refactors and removes unnecessary code

Great work!
Attachment #703221 - Flags: review?(crdlc) → review+

Comment 15

5 years ago
https://github.com/mozilla-b2g/gaia/commit/862e88fc423ce3890ce122c06bf512e9cfd2e29b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-b2g18: --- → fixed

Comment 16

5 years ago
verified 
build id: 20130124140859
Status: RESOLVED → VERIFIED
Landed on mozilla-b2g18/gaia master prior to the 1/25 branching to mozilla-b2g18_v1_0_0/v1.0.0, updating status-b2g-v1.0.0 to fixed.
status-b2g18-v1.0.0: --- → fixed
You need to log in before you can comment on or make changes to this bug.