Closed Bug 830381 Opened 9 years ago Closed 9 years ago

HTTP GET request issued twice for images with no explicit expiration date

Categories

(Firefox :: Untriaged, defect)

18 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 583351

People

(Reporter: vandonr, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130104151925

Steps to reproduce:

Display an image in firefox


Actual results:

HTTP GET request to fetch the image is fired twice if the response doesn't contain a max-age argument or anything related to caching.
One can see it using the firefox extension LiveHttpHeader, and loading this image for instance : http://www.lateteatoto.org/crbst_LOGO_20Retravaill_C3_A9_201_20gif.gif?t=1r834wntfj24364


Expected results:

Only one request to the server should be sent. 
BTW, that's how IE and Chrome behave.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583351
You need to log in before you can comment on or make changes to this bug.