Closed Bug 830407 Opened 8 years ago Closed 8 years ago

Delayed selection confuses screen readers

Categories

(Firefox :: Downloads Panel, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mak, Assigned: mano)

References

Details

(Keywords: helpwanted)

(In reply to Marco Zehe (:MarcoZ) from comment #5)
> 3. When opening the downloads view, focus is not always placed in the list.
> Sometimes, one has to press DownArrow to get focus to anything. Before that,
> it appears as if the keyboard focus is on the frame/window. If possible, it
> should always be in the list of downloads.
With VoiceOver I'm not sure I can tell the difference (by the way, it seems the richlistbox is reported as a menu to VoiceOver). Someone who has access to a Windows screen reader will have to test this and log the difference.

In particular, it has to be verify that it is indeed an accessibility issue, and not some failure to select the first item.

If it is an accessibility issue, it means that select events are not reported when the richlistbox is already focused. This doesn't make sense though, because how would it report the selection change as you move between items using the keyboard? The richlistbox is already focused at that point.
assigning to Mano to try reproducing the issue with NVDA.
Help is welcome though.
Assignee: nobody → mano
Keywords: helpwanted
I can reproduce this. However, I don't believe it is specific to accessibility.

On my system, when I press control+j, the downloads list does not get focus. I have to press shift+tab to focus it. There are two reasons I believe this is not specific to accessibility APIs:
1. If it were accessibility specific, pressing shift+tab would take me to the control prior to the downloads list. Instead, it takes me to the downloads list itself.
2. Pressing up arrow, down arrow or the applications key does nothing.
Unless there is some very strange interaction going on, anyone should be able to reproduce this via the keyboard.
(In reply to James Teh [:Jamie] from comment #3)
> On my system, when I press control+j, the downloads list does not get focus.

Is this on today's nightly?
CTRL+J for me definitely gives the list focus and I can just press down to move in the list.
Do you have downloads in the list?

Something to verify:
1. download something, close the browser, reopen the browser, CTRL+J (this is the case where we have some historical download)
2. Clear Downloads (so list is empty), close the library. Download something and CTRL+J (this is the case where we have some session download)
Can you still reproduce on current Nightly? Could you please check my questions in comment 4?
Flags: needinfo?(jamie)
For me, the current nightly works great. Jamie, can you confirm that the list and in it, the first item, now get focus properly?
Works correctly for me now in current nightly for both cases.
Flags: needinfo?(jamie)
Thank you very much for testing, resolving per comment 6 and comment 7.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.