Closed Bug 830435 Opened 11 years ago Closed 11 years ago

Massive regression in session-restore times

Categories

(Firefox :: Session Restore, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: taras.mozilla, Assigned: Yoric)

References

Details

See http://is.gd/P2xerl

We should backout the new session-store change aurora(& higher if it made it). Mark reported this after seeing a 47second startup.
Note there is a regression in reading from session-store. However session-restored notification(offset by a week from this), actually got better. Ideas? http://is.gd/FehIkY
(In reply to Taras Glek (:taras) from comment #1)
> Note there is a regression in reading from session-store. However
> session-restored notification(offset by a week from this), actually got
> better. Ideas? http://is.gd/FehIkY

sorry, misread the graph. Our startup measures improved across the board on Dec1st(not sure why). Then session-restored async-ification regressed compared to non-async code. This could be due to a busy main thread during startup(and thus ok), I'd like to verify that.
Metrics started bucketing the simple measures differently on Dec 1st
A few theories:
1. the OS.File shared I/O thread is busy, so we have to wait before reading the file (unlikely);
2. the main thread is busy after we have read the file with OS.File, so we have to wait before receiving notification of completion;
3. OS.File reads are very slow for some reason;
4. the refactoring of bug 532150 makes reading slow for some reason.

As discussed with Taras, some A/B testing will tell us whether it's 4.

Note that 3. is possible, as |OS.File.read| currently requires two I/O operations (a |stat| and an actual |read|), hence 2 back-and-forth communications with the I/O thread. Fixing this should be rather straightforward now that bug 720949 has landed.
Actually, I'm not going to do the A/B testing just yet, because I'm pretty sure I have found (and fixed) the issue: bug 830694.
If I read the histograms correctly it doesn't seem to have improved since bug 830694 landed.
Bug 848278 should let us examine the speed of the OS.File operation.
Depends on: 848278
Most likely a false alert.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.