Install fails to fire on opening jre.xpi (browser hangs)

VERIFIED FIXED

Status

SeaMonkey
Installer
--
blocker
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: James Green, Assigned: Sean Su)

Tracking

({hang, regression})

Trunk
x86
Linux
hang, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Using Linux cvs builds for some time now, including today's tip:

1. Download Sun's jre.xpi to a local disk.
2. Open mozilla, and type into the urlbar: file:///path/to/jre.xpi

Expected result:
Should open the installer dialog and install the xpi

Actual result:
I got a download dialog asking whether it should download to disk or opened with
another application.

This blocks me from using Java. I'm on Debian Unstable.
(Reporter)

Comment 1

17 years ago
I'm told this is a known bug, but I've filed anyway since doron and I can't find
any existing ones.
Keywords: mozilla0.9.2, regression
(Reporter)

Updated

17 years ago
Summary: Install files to fire on opening jre.xpi → Install fails to fire on opening jre.xpi

Comment 2

17 years ago
How about bug 79617 ?

Updated

17 years ago
QA Contact: gemal → gbush

Comment 3

17 years ago
I had a similar prob with moz 0.8. Bug 62725. Moz wouldn't resolve
'ftp.netscape.com', never started d/ling. 

Now, ftp resolves, but no d/l. If loaded from the local filesystem, installation
never begins. 

Comment 4

17 years ago
Sorry, needed root. It was forcing to /usr/lib/mozilla. Maybe there should be a
note about that, or optional install location. 
(Reporter)

Comment 5

17 years ago
Just re-tried this with today's tip, and it's worse. Now I get an immediate
hang, the CPU doesn't peg or anything, but I can see using 'ps ax' that one of
the mozilla threads is consuming cpu time. I have to kill them off and start
again. Reproducable always.

I'm upping this to Blocker, since not only can I not install Java, but any
attempts to install it hangs the browser too now :(  Adding more keywords.

Just to confirm, I do indeed have write priveleges to the mozilla installation
directories.
Severity: critical → blocker
Keywords: nsbeta1, nsCatFood, rtm
Summary: Install fails to fire on opening jre.xpi → Install fails to fire on opening jre.xpi (browser hangs)
(Reporter)

Updated

17 years ago
Keywords: hang

Comment 6

17 years ago
I have found this problem in build 2001060XXX, however bug 79617 answer was in
bug 80171, but I'm not a heavy code person and found that bug 80964 has a good
solution.  Instead of using the link at http://www.mozilla.org/release/ use the
link at http://home.netscape.com/plugins/jvm.html.

I'm told that the code will be placed into 0.9.2 but until that's released you
may want to try this.

Thanks.
(Reporter)

Comment 7

17 years ago
I'll try the link, but my tests have been based on jre.xpi having already been
downloaded to my home directory, no downloading by mozilla neccessary.

Comment 8

17 years ago
Fixed. Reopen if I'm wrong, but we landed a fix that should address this.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
Syd, 

I don't see reference to what may have fixed this- but could it have anything to 
do with bug 89488? (- if I install Java using installer or as a plugin I am 
hanging.)

Comment 10

17 years ago
verified on mozilla build 2001072004
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.