FF 18 wont load any pages that use HTTPS from links or the google search bar when using a manually entered proxy.

RESOLVED DUPLICATE of bug 828236

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 828236
5 years ago
5 years ago

People

(Reporter: morpheustdk, Unassigned)

Tracking

18 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Setup:-
On our work machines myself and a colleague allowed FF17.0.1 (British) to upgrade to FF18. We use a manually configured proxy server with the all protocols flag ticked and with a few internal sites excluded. The problem occurs in two scenarios :-

1. Click on a link on any site that uses the https protocol
2. Enter a search term into the blue google search icon box (this changed from the multicoloured version of FF17 with the upgrade). Other search providers and the google UK search provider works.

Reinstall Firefox 17.0.1 and repeated the above, no errors will occur.

Please the the following Mozillazine thread for others experiencing this issue: http://forums.mozillazine.org/viewtopic.php?f=9&t=2640569&sid=6a58d86efc66aaaa26366fb68d47c085&p=12601097#p12601097


Actual results:

In both of the above cases  the proxy returns a connection refused error.


Expected results:

This should have behaved the same as FF17.0.1 and either taken me to the link I clicked or performed a google search when using the search box.
(Reporter)

Updated

5 years ago
Version: 17 Branch → 18 Branch
This should be a dupe of bug 828236
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 828236
you can try a build with the likely fix for this here:

http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/mcmanus@ducksong.com-95a9f44c52fd/
You need to log in before you can comment on or make changes to this bug.