Closed Bug 830609 Opened 7 years ago Closed 7 years ago

click gets offset by a couple of rows in object inspector

Categories

(DevTools :: Console, defect)

21 Branch
x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: kamathln, Unassigned)

References

Details

Attachments

(1 file)

Attached image Cursor_offset.jpg
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20130112 Firefox/21.0
Build ID: 20130112030947

Steps to reproduce:

1) opened web console
2) entered "document" in js command line and pressed return.
3) clicked on the resulting output, (listed as > [object HTMLDocument] and underlined)
4) clicked on the first item in the resulting box "Inspect: Document"


Actual results:

The third item got clicked


Expected results:

The first item should have got clicked
WFM with 2013-01-15-03-09-36-mozilla-central-firefox-21.0a1.en-US.linux-x86_64, Xfce.
Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20130112 Firefox/21.0
Build ID: 20130112030947 and 20130122030956

I get the same behavior but only if the browser is not in full screen. In full screen mode, it behaves normally.
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools: Console
Ever confirmed: true
This issue is caused by the XUL panel element which is rather buggy. We will move away from using that in bug 808370.
Depends on: 808370
Aleksej [:Aleksej] Is your main Firefox window's origin at 0,0 relative to the screen origin? Please move it and try again. Bogdan Maris [QA]'s comment about fullscreen browser is what gave me the clue. I tried moving the main window around and noticed it has a direct effect on the offset in the Object Inspector window.
(In reply to Laxminarayan G Kamath A from comment #4)
Yes, reproduced.  Also note how the Inspector window is moving when you move the main window.
Duplicate of this bug: 837867
We replaced the object inspector popup with the variables view, which is now in a sidebar. See bug 808370.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.