crash if data cannot be found in an Object tag

VERIFIED FIXED

Status

SeaMonkey
General
--
critical
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: chris, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.4 i686; en-US; rv:0.9+) Gecko/20010528
BuildID:    2001052808

If the reference to the object's data is to an item that doesn't exist then the
browser crashes.

Reproducible: Always
Steps to Reproduce:
1.load a page with this tag:
 <OBJECT data="noimage.gif" type="image/gif"></OBJECT>


Actual Results:  The browser crashes.

Expected Results:  The object tag is not rendered because the data cannot be found.

This will cause a crash since the image cannot be found.
<OBJECT data="noimage.gif" type="image/gif"></OBJECT>

This will not crash because the image can be found:
<OBJECT data="http://www.mozilla.org/images/mozilla-banner.gif"
type="image/gif"></OBJECT>

Comment 1

17 years ago
Created attachment 36621 [details]
Testcase, beware crashes browser

Comment 2

17 years ago
Attachment is testcase. Crashes Linux 2001052908 hence confirmed NEW

This may very well be related to bug #83259 where an unclosed OBJECT crashes
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

17 years ago
Tested again with build ID: 2001053008 on Linux and the testcase didn't cause a
crash.

Must have been fixed...

Chris
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 4

16 years ago
if you don' tknow why a problem went away, you should use worksforme, not fixed
rs vrfy wfm
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.