[Dialer] when a SIM is out of money on the card, the error message to place more money on the phone is blank

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:-, b2g18-)

Details

(Whiteboard: interaction [UX-P2])

Attachments

(3 attachments)

Created attachment 702277 [details]
french screenshot.

## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/f2460bf17811
Gaia   693a1b8e123eb9e8084231692cc8d89eba182be5
BuildID 20130114230201
Version 18.0
Otoro

## Repro :
1. place in a prepaid Sunrise card into the device that ran out of money
2. try to place a call

## Expected :
1. there is some sort of message in french stating to recharge the phone

## Actual :
1. blank

## Note :
1. happens in French and English
blocking-b2g: --- → tef?
tracking-b2g18: --- → ?

Updated

5 years ago
Whiteboard: interaction [UX-P2]
ferjm, can you have a look at this one
Flags: needinfo?(ferjmoreno)
Gaia Triage : we need someone w/ a SIM card that we are going to use in production to test.  The SIM card I used was a Swiss SIM prepaid card.
I would need a SIM card from the carriers that you mention...

Could you attach a logcat with the RIL debugging enabled, please?
Flags: needinfo?(ferjmoreno)
This is not happening with Movistar or VIVO Pre-paid Cards.
blocking-b2g: tef? → shira?
Created attachment 704054 [details]
logcat w/ RIL debug turned on

The call was made at : 01-18 21:05:15.256
It seems you aré receiving a network initiated USSD. The plan was not supporting this feature in V1, but there might some unexpected behavior. Fernando may provide more details.
Flags: needinfo?(ferjmoreno)
(In reply to Daniel Coloma:dcoloma from comment #7)
> It seems you aré receiving a network initiated USSD.

Yes

> The plan was not
> supporting this feature in V1, but there might some unexpected behavior.
> Fernando may provide more details.

Network initiated USSDs are supported since Bug 820292 landed.

We are indeed receiving an USSD:

01-18 21:05:17.849: I/Gecko(434): -*- RILContentHelper: Received message 'RIL:USSDReceived': {"rilMessageType":"USSDReceived","message":"Unfortunately there is insufficient credit on your sunrise pronto account for the required call. Please reload your credit account.","sessionEnded":true

And we are also probably sending its corresponding system message, as the USSD screen is being opened, but for some reason the message is not being properly displayed.
Assignee: nobody → ferjmoreno
Flags: needinfo?(ferjmoreno)
Keywords: regression
:kev, is this an impact to v1.0.1 markets?
Flags: needinfo?(kev)

Comment 10

5 years ago
Kev, could we ask the carrier to help the testing and see if this issue could be reproduced with this carrier? Thanks.

Updated

5 years ago
Whiteboard: interaction [UX-P2] → interaction [UX-P2], [TEF_REQ]
Want to make sure everyone knows that Shira is targeting 2/15 code freeze. 
Shira+ bugs needs more attention for unassigned, needinfo?,  review?
Full regression test is planned on 2/6. Need to have shira+ bugs landed by the end of 2/5 to be covered in full regression testing. Thanks
I've been doing tests to check network initiated USSDs and they work as expected with Movistar, Vodafone and O2 SIMs. I cannot reproduce this issue.
Assignee: ferjmoreno → nobody

Updated

5 years ago
Whiteboard: interaction [UX-P2], [TEF_REQ] → interaction [UX-P2]
andreas.utrap, do you think you can provide some feedback here for the v1.0.1 target markets? thanks
Flags: needinfo?(kev) → needinfo?(andreas.utrap)
From what we've heard in email this is not an issue currently as the shira market SIMs check USSDs and would also work as expected, please renom if further investigation proves this to no longer be true.
blocking-b2g: shira? → -
Since this happened with a French SIM, marking leo? in case this affects their markets.
blocking-b2g: - → leo?
The only thing we need to know here to decide on tracking/blocking is whether this is working or not on Polish SIM card(s) we are shipping with.
Keywords: qawanted
blocking-b2g: leo? → -
heard back from Andreas in email and this does not affect Polish SIM either - not tracking
tracking-b2g18: ? → -
Flags: needinfo?(andreas.utrap)

Updated

5 years ago
Keywords: qawanted
This bug is out of date and we suspect that it's no longer valid. If you think this is in error, please reopen it.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.