The blocklist page for Acrobat Reader is incorrect/misleading

NEW
Unassigned

Status

()

6 years ago
a year ago

People

(Reporter: benjamin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I have Acrobat 10.0.1.434 installed on Windows. In the addons manager it is listed as "known to be vulnerable", which is probably correct. But the "Update Now" link points to this page:

https://addons.mozilla.org/en-US/firefox/blocked/p156

Which only mentions Acrobat Reader 9.5.1 and earlier. That page should be updated.
(Reporter)

Updated

6 years ago
OS: Linux → Windows 7
That's odd, you should be pointed to https://addons.mozilla.org/en-US/firefox/blocked/p158.

Both blocks appear to be correct on AMO. Can you confirm that about:plugins reports the right version, and that your blocklistURL pref is pointing to production?
(Reporter)

Comment 2

6 years ago
All of my blocklist prefs appear to be the default setting. From about:plugins:

    File: nppdf32.dll
    Version: 10.0.1.434
    Adobe PDF Plug-In For Firefox and Netscape 10.0.1
Moving this over to the Add-ons Manager, since the blocks appear to be correct and I can only think this is a bug when getting the version number from the plugin.
Component: Blocklisting → Add-ons Manager
Product: addons.mozilla.org → Toolkit
Hmm, the blocklist entries do appear to be correct and behaving correctly, when matching against the "10.0.1.434" version thing. No idea what's up.
You need to log in before you can comment on or make changes to this bug.