Crash [@ __libc_android_abort | __android_log_assert | android::OMXCodec::signalBufferReturned(MediaBuffer*)]

RESOLVED DUPLICATE of bug 823324

Status

()

Core
Audio/Video
--
critical
RESOLVED DUPLICATE of bug 823324
6 years ago
6 years ago

People

(Reporter: cjones, Unassigned)

Tracking

({crash})

unspecified
ARM
Gonk (Firefox OS)
crash
Points:
---

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [b2g-crash], crash signature)

Attachments

(1 attachment)

Created attachment 702418 [details]
Processed dump + .extra + dump-lookup

Seen while running [1].  Launching the video app for the first time after a full flash triggered the crash.

We're failing this assertion

void OMXCodec::signalBufferReturned(MediaBuffer *buffer) {
...
    for (size_t i = 0; i < buffers->size(); ++i) {
...
        if (info->mMediaBuffer == buffer) {
...
            CHECK_EQ((int)info->mStatus, (int)OWNED_BY_CLIENT);

[1] https://wiki.mozilla.org/B2G/Memory_acceptance_criteria#MW0:_Every_app_is_successfully_launched_into_the_foreground
Crash Signature: Crash [@ __libc_android_abort | __android_log_assert | android::OMXCodec::signalBufferReturned(MediaBuffer*)] → [@ __libc_android_abort | __android_log_assert | android::OMXCodec::signalBufferReturned(MediaBuffer*)]

Comment 1

6 years ago
Crash signatures in 18.0 don't have parenthesis.

This crash signature is #4 top crasher in B2G 18.0 even after the fix of bug 823324.
Severity: normal → critical
Crash Signature: [@ __libc_android_abort | __android_log_assert | android::OMXCodec::signalBufferReturned(MediaBuffer*)] → [@ __libc_android_abort | __android_log_assert | android::OMXCodec::signalBufferReturned(MediaBuffer*)] [@ __libc_android_abort | __android_log_assert | android::OMXCodec::signalBufferReturned]
tracking-b2g18: --- → ?
Keywords: crash
Whiteboard: [b2g-crash]
Oops!

That patch landed in a downstream repository, it's not integrated into moz builds.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 823324
blocking-b2g: tef? → -

Comment 3

6 years ago
(In reply to Chris Jones [:cjones] [:warhammer] from comment #2)
> That patch landed in a downstream repository, it's not integrated into moz
> builds.
Bug 823324 is fixed in b2g-18 and not this one. Are you sure it's a duplicate?
Pretty sure; the signatures are the same and that crash isn't showing up in downstream builds.

Updated

6 years ago
tracking-b2g18: ? → ---
You need to log in before you can comment on or make changes to this bug.