[App Updates] Disabling all checkboxes in the update prompt, hitting later, and return prompt - checkboxes are enabled, but download button is disabled

VERIFIED FIXED in 1.1 QE1 (5may)

Status

Firefox OS
Gaia::System
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: Leo)

Tracking

unspecified
1.1 QE1 (5may)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18- verified)

Details

(Whiteboard: [TD-8923] [QE1])

Attachments

(1 attachment)

196 bytes, text/html
julienw
: review+
Details
(Reporter)

Description

5 years ago
Build: B2G 18 1/15/2013
Device: Unagi

Steps:

1. Find an app update on your device
2. Select the update prompt
3. Uncheck each checkbox for each app
4. Hit "Later"
5. Select the update prompt again

Expected:

The checkboxes should be enabled and the download button should be enabled.

Actual:

The checkboxes are enabled, download button is disabled. Easy to work-around, but an annoying inconsistency.
(Reporter)

Updated

5 years ago
Blocks: 728081
tracking-b2g18: --- → ?
Patches welcome, but this isn't likely to draw much attention over other work in v1.
tracking-b2g18: ? → -
(Reporter)

Updated

5 years ago
Duplicate of this bug: 858354
(Assignee)

Comment 3

5 years ago
Wayne, would you apply leo+ to this bug, since the Bug 858354 has been resolved-duplicate.
Flags: needinfo?(wchang)
(Assignee)

Updated

5 years ago
Whiteboard: TD-8923
(Reporter)

Comment 4

5 years ago
(In reply to leo.bugzilla.gaia from comment #3)
> Wayne, would you apply leo+ to this bug, since the Bug 858354 has been
> resolved-duplicate.

I'll nom first per your request.

FWIW, we didn't block nor track this originally, because the workaround here is simple. It's awkward, though.
blocking-b2g: --- → leo?
Flags: needinfo?(wchang)
(Assignee)

Comment 5

5 years ago
Hi Jason, 

The fix is real simple, just adding updateDownloadButton() call at the end of showDownloadPrompt function in update_manager.js

I'm making the pull request now, hopefully this patch can be pushed in.

Thanks
(Assignee)

Comment 6

5 years ago
Created attachment 737330 [details]
Pull request url
Assignee: nobody → leo.bugzilla.gaia
Attachment #737330 - Flags: review?(timdream)
(Assignee)

Updated

5 years ago
Attachment #737330 - Attachment mime type: text/plain → text/html
Please add an unit test for this case.

The update functionality has a quite comprehensive suite and I'd like to keep it this way.

Thanks !
Comment on attachment 737330 [details]
Pull request url

Redirect review
Attachment #737330 - Flags: review?(timdream) → review?(felash)
leo+ as this is one of the blocking bugs from the QE1 test cycle.
blocking-b2g: leo? → leo+
Whiteboard: TD-8923 → TD-8923 [QE1]
(Assignee)

Updated

5 years ago
Whiteboard: TD-8923 [QE1] → [TD-8923] [QE1]
Target Milestone: --- → Leo QE1 (5may)
(Assignee)

Comment 10

5 years ago
Hi Julien,

I have added a unit test for this. Please review again. Thanks!


(In reply to Julien Wajsberg [:julienw] from comment #7)
> Please add an unit test for this case.
> 
> The update functionality has a quite comprehensive suite and I'd like to
> keep it this way.
> 
> Thanks !
Comment on attachment 737330 [details]
Pull request url

r=me

thanks a lot !
Attachment #737330 - Flags: review?(felash) → review+
master: 671e2b3a0ac28c77930a795414df48c7d6690359
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted 671e2b3a0ac28c77930a795414df48c7d6690359 to:
v1-train: 3774a756e70ec322d363b49d29fea43c5b214cff
status-b2g18: --- → fixed
(Reporter)

Updated

5 years ago
Keywords: verifyme
QA Contact: jsmith
(Reporter)

Comment 14

5 years ago
Verified on 4/18 build.
Status: RESOLVED → VERIFIED
Keywords: verifyme
(Reporter)

Updated

5 years ago
status-b2g18: fixed → verified
(Reporter)

Updated

5 years ago
Flags: in-moztrap?

Updated

5 years ago
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.