Gaia build/settings.py fails with 'invalid syntax' on with Python version 3+

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
a year ago

People

(Reporter: andrew.livesay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121201125707

Steps to reproduce:

Ran "DEBUG=1 make"


Actual results:

Build failed with several Python 3 compatibility issues (eg, 'invalid syntax')


Expected results:

Build should have completed without error.

Comment 1

6 years ago
Not sure if this was asserted yet, but the Makefile is pretty clear to assume that the user has python 2.7.x installed since python 3 is not supported.
Thanks for filing this bug. As the bug was filed a long days ago, I suppose it may have been resolved. Would you kindly check again and let me know , if you can re produce the bug Now or not. This thing will be really appreciated.

If you could re produce the bug , please let me know your device name and OS version.

Regards
Flags: needinfo?(andrew.livesay)

Updated

4 years ago
Component: Gaia → Gaia::Build
Current build system has re-written settings.py to settings.js.

See also: https://wiki.mozilla.org/Gaia/Build/Refactoring_Plan/First_half_of_2014
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Flags: needinfo?(andrew.livesay)
You need to log in before you can comment on or make changes to this bug.