Camera - preview doesn't always appear on screen after taking photos

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: mikeh, Assigned: mikeh)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18+)

Details

This may be related to bug 826765, but is _NOT_ the same as bug 830995.  In bug 830995, the camera driver thread appears to be deadlocked; in this bug, the camera thinks it is running correctly!  If you press the shutter button, the camera takes a picture, and eventually the thumbnail appears at the top of the screen, but the viewfinder remains blank/black.

Tapping the home button and tapping the camera icon on the homescreen does not fix the problem.

Force-closing the camera and reopening it fixes the problem.
Assignee: nobody → mhabicher
blocking-b2g: --- → tef?
STR:
1. open camera app
2. take photos
3. tap home button to return to home screen
4. press power button to sleep DUT
5. press power button again to wake DUT
6. swipe up and press unlock
7. enter passcode
8. tap camera icon

Camera app is now open and the UI is responsive, but the preview is blank.
marcia, FYI.

Updated

5 years ago
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
blocking-b2g: tef? → -
tracking-b2g18: --- → +
Keywords: qawanted

Comment 3

5 years ago
With unagi 2012/23/01 build:
Gaia 1890022
Gecko6a506d1
The previews can be seen ok by tapping on the screen
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.