Closed Bug 831091 Opened 12 years ago Closed 12 years ago

Trusted UI currently uses 'Mozilla Marketplace' as title - should be 'Marketplace'

Categories

(Marketplace Graveyard :: Payments/Refunds, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jedp, Assigned: cvan)

References

Details

(Whiteboard: interaction)

Attachments

(2 files)

Attached image Mozilla Marketplac...
If the Trusty UI's title is set to "Mozilla Marketplace", it truncates it to "Mozilla Marketplac..."

If Mozilla Marketplace is the default title for the UI when launched by Marketplace, it should not be truncated.  (Ironically, the lacuna occupies more horizontal space than the letter e.)
Can we reduce the type size of the title? It appears a little large.

checkout the style guide for visual reference:
https://www.dropbox.com/s/i41tjejo3kxmm75/ID_Payments.psd
Please stop using "trusty UI".  It makes it impossible to search for bugs related to trusted UI.
Summary: Trusty UI truncates 'Mozilla Marketplace' title → Trusted UI truncates 'Mozilla Marketplace' title
This is a marketplace bug - the title is supposed to be "Firefox Marketplace"
Component: Gaia::System → Consumer Pages
Product: Boot2Gecko → Marketplace
Version: unspecified → 1.0
blocking-b2g: tef? → ---
Summary: Trusted UI truncates 'Mozilla Marketplace' title → Trusted UI currently uses 'Mozilla Marketplace' as title - should be 'Firefox Marketplace'
Blocks: marketplace-payments
No longer blocks: 813811
Jason, sorry if I misfiled it.  I placed it under gaia with the reasoning that even though this is a bug that affects marketplace, it's not marketplace that's causing the title to be truncated; it's the behavior of the trusted ui itself.
jsmith: How is this a Marketplace Consumer Pages bug?
(In reply to Chris Van Wiemeersch [:cvan] from comment #5)
> jsmith: How is this a Marketplace Consumer Pages bug?

Screwed up. Should be in the payments bucket.
Component: Consumer Pages → Payments/Refunds
(In reply to Jed Parsons [:jparsons] from comment #4)
> Jason, sorry if I misfiled it.  I placed it under gaia with the reasoning
> that even though this is a bug that affects marketplace, it's not
> marketplace that's causing the title to be truncated; it's the behavior of
> the trusted ui itself.

Right, but truncation is expected if we don't have room for X+ characters. That's expected behavior by the design for how gaia app names work. Let me fix the naming - should be "Marketplace"
Summary: Trusted UI currently uses 'Mozilla Marketplace' as title - should be 'Firefox Marketplace' → Trusted UI currently uses 'Mozilla Marketplace' as title - should be 'Marketplace'
Component: Payments/Refunds → Gaia
Product: Marketplace → Boot2Gecko
Version: 1.0 → unspecified
Talked with Jed - the issue is in the app manifest in Gaia. We need to fix the naming.
I've just checked the marketplace app's manifest in gaia, and it's as already as it should be.  What I've been looking at here was actually title resulting from the marketplace-dev manifest, which marketplace uses for testing, and which has the fuller title ("Mozilla Marketplace (Dev)").  I did not notice the titles were so different until now.

Comment 3 says we want "Firefox Marketplace" (not Mozilla?), and comment 6 accepts "Marketplace"

I'm wondering whether the characters " (Dev)" at the end of the marketplace-dev title are what pushed it over the edge.  

I propose we simply try changing the title of marketplace-dev to "Firefox Marketplace" or "Mozilla Marketplace" to test the spacing if those are the preferred spellings. 

otherwise, if mere "Marketplace" is ok, then I believe no action is required - the marketplace app manifest already says "Marketplace" as the title.
Jason - I've confirmed by noodling with gaia a bit more:

The "Mozilla Marketplac..." truncation was caused by the full title "Mozilla Marketplace (Dev)"

I've had it display both "Mozilla Marketplace" and "Firefox Marketplace" in the trusted ui title, and they both fit fine.

The style guide in comment #1 indicates that "Mozilla Marketplace" is the desired title.  If all concur with that, then it's a simple matter to update the marketplace manifest's title.
https://github.com/mozilla/zamboni/commit/789da9d

Changed it to "Firefox Marketplace." If someone wants something else, reopen it.
Assignee: nobody → cvan
Status: NEW → RESOLVED
Closed: 12 years ago
Component: Gaia → Payments/Refunds
Product: Boot2Gecko → Marketplace
Resolution: --- → FIXED
Target Milestone: --- → 2013-01-17
Version: unspecified → 1.0
Flipping quick bit to b2g to remove the tracking flag...
Component: Payments/Refunds → General
Product: Marketplace → Boot2Gecko
Target Milestone: 2013-01-17 → ---
Version: 1.0 → unspecified
Component: General → Payments/Refunds
Product: Boot2Gecko → Marketplace
Version: unspecified → 1.0
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: