Submit form actived loading image (downright) and stopped again and nothing happend

VERIFIED WORKSFORME

Status

()

Core
Layout: Form Controls
--
major
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Jonas, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9+) Gecko/20010512
BuildID:    2001051220

<form action="/index.php?contentID=addNews&edit=insert&insert=true"
enctype="multipart/form-data" method="post"><input type="hidden" name="visitor"
value="2b73d6b457d4e31a2114b9b31dd93201" />
<table border="0" cellspacing="1" cellpadding="1">
<tr><td><span class="mainHeader">add a new news entry</span></td><tr>
<tr><td height="2" colspan="2"><img src="gfx/borderLine2.jpg" width="390"
height="2"></td></tr>
<tr><td valign="middle"><span class="mainContent">topic: </span><font
face="arial" size="-2"><input type="text" size="40" maxlength="50"
name="newsHead"></font></td></tr>
<tr><td valign="middle"><span class="mainContent">kind of: </span><select
name="newsIcon">
        <option value="img/news/icons/leagues.gif"> league </option>
        <option value="img/news/icons/clans.gif"> clans </option>
        <option value="img/news/icons/files.gif"> files </option>
        <option value="img/news/icons/demos.gif"> demos </option>
        <option value="img/news/icons/news.gif" selected> news </option>
        <option value="img/news/icons/configs.gif"> configs </option>
        <option value="img/news/icons/lans.gif"> lans </option>
        <option value="img/news/icons/servers.gif"> servers </option>
        <option value="img/news/icons/community.gif"> community </option>
    </select></td></tr><tr><td valign="middle"><span class="mainContent">body:
</span><br><font face="arial" size="-2"><textarea name="newsContent" cols="45"
rows="15" wrap="virtual"></textarea></font></td></tr>
<tr><td valign="middle"><span class="mainContent">image 1: </span><input
type="file" name="localImage1"></td></tr>
<tr><td valign="middle"><span class="mainContent">image 2: </span><input
type="file" name="localImage2"></td></tr>
<tr><td valign="middle"><span class="mainContent">image 3: </span><input
type="file" name="localImage3"></td></tr>
<tr><td valign="middle"><input type="submit" name="modnewsform"
value="Submit">&nbsp; <input type="reset" value="Reset"></td></tr>
<tr><td>&nbsp;</td><tr>
</table>
</form>

<!-- index.php is the file this html data is written in, m$ internet exploder
5.0x works fine, Netscape® Communicator 4.77 works fine too, opera 5.2x does'nt
set/upload files right but passes texts -->

Reproducible: Always
Steps to Reproduce:
1.created a <form> using enctype="form-data/multipart"; forms without ectype work.

2./3. i chose my admin section *G* and tried to add files - nothing happend.

Actual Results:  nothing - only the animation starts when you push submit -
nothing else.

Expected Results:  upload text and files using the http get method

Comment 1

17 years ago
I have no problems uploading files with ENCTYPE=multipart/form-data on my own
server. Please try a more recent build and see if the problem persists. Thanks.

Comment 2

17 years ago
reassigning
Assignee: rods → pollmann
(Assignee)

Comment 3

17 years ago
There was a problem with HTTP redirects that was fixed in recent builds that had
these exact symptoms.  Marking WORKSFORME because all the similar test cases to.
 Reporter, please try a more recent build and see if you still have the problem,
thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
jonashartmann@gmx.de (Jonas) Could you please test if this is still happening?

Comment 5

17 years ago
verifying due to lack of responce. Please reopen if the problem occurs again.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

16 years ago
I didnt know bugzilla much when i reported the bug.
the webpage is long down (not online) but i had a copy and tried it out - it
works fine now (mozilla 2002 0530 12)
You need to log in before you can comment on or make changes to this bug.