Disable regions which don't support payments

RESOLVED DUPLICATE of bug 825331

Status

P2
normal
RESOLVED DUPLICATE of bug 825331
6 years ago
6 years ago

People

(Reporter: clouserw, Assigned: basta)

Tracking

(Blocks: 1 bug)

2013-01-17
Points:
---

Details

(Whiteboard: u=dev p=)

(Reporter)

Description

6 years ago
If a user has a paid app, we can't show the app in all the stores, only the ones where we have payment providers which the person is registered with.  This bug includes but is not limited to:

- Add a flag to each region object which is an array of payment providers.  For now it's bango, that's fine, the important part is an empty array means no payments

- Disable the regions in the dev control panel which either don't have payment providers or which the developer doesn't have a payment provider account with

- Disable "rest of the world" - there are no payments here at this point in time.  This also disables the "and any new regions."  We'll have to live with that for now.

- If a person has all the regions selected and flip from free->paid we should remove the regions following the logic above
(Assignee)

Comment 1

6 years ago
Bram has already addressed a lot of this and I'm working on this very implementation right now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 825331
You need to log in before you can comment on or make changes to this bug.