[FM Radio] No sound in FM Radio App

RESOLVED DUPLICATE of bug 830657

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 830657
5 years ago
5 years ago

People

(Reporter: scravag, Assigned: rlin)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:tef+)

Details

(Reporter)

Description

5 years ago
gecko-b2g18: 0a7c51803227
gaia: 332f707c72d56399a7740039cd85ba509586fb20

STR:
Plug headset launch FM Radio

Expect:
Sound in the headset

Actual:
No sound in the headset
(Reporter)

Updated

5 years ago
blocking-b2g: --- → tef?
(Reporter)

Updated

5 years ago
Component: Gaia::FMRadio → General
QA Contact: jshih
Hi David,
I think this should be the same as 
Bug 830657 - [FM Radio] No sound on the second launch of the application
Status: NEW → UNCONFIRMED
Ever confirmed: false
(Reporter)

Updated

5 years ago
Assignee: nobody → rdow
blocking-b2g: tef? → tef+
Keywords: regression
correct assignee to rlin
and per david, STR-wise this is different from bug 830657
Assignee: rdow → rlin
QA, please verify STR here
Keywords: qawanted

Comment 4

5 years ago
Test Environment:
Device: unagi phone
Build Identifier: 20130118070201
Update channel: nightly
Git commit info: 2013-11-18 08:29:43 
Gaia Version: 7b8dea7e7ec3
Gecko Version: a23cb7f20c34

Steps to reproduce:
1. Plug in headset.
2. Launch the FM Radio app.
3. Scroll through the spectrum. Nod your head to the music till you recall the real purpose of doing this.
4. Yank the headset out of the phone and plug in again.

Actual results:
There is sound in the headphones on the first launch of the FM Radio app, but not on subsequent launches.

adb logcat:
I/FMRadio (  109): Antenna state is changed!
W/AudioFlinger(  117): Thread AudioOut_1 cannot connect to the power manager service
W/AudioHardwareMSM76XXA(  117): rpc_snd_set_device(27, 0, 0)
W/AudioHardwareMSM76XXA(  117): rpc_snd_set_device(6, 1, 0)
E/GeckoConsole(  518): Content JS LOG at app://fm.gaiamobile.org/js/fm.js:142 in updatePowerUI: Power status: off
I/FMRadio (  109): Antenna state is changed!
W/AudioPolicyManager(  117): FM started in 2 Mode
W/AudioHardwareMSM76XXA(  117): Enabling Anlg FM on wired headset
W/AudioHardwareMSM76XXA(  117): rpc_snd_set_device(35, 1, 0)
W/AudioPolicyManager(  117): setDeviceConnectionState() device already connected: 4
I/qcom-fm (  719): /system/etc/init.qcom.fm.sh: In FM shell Script 
I/qcom-fm (  720): /system/etc/init.qcom.fm.sh: mode: normal 
I/qcom-fm (  721): /system/etc/init.qcom.fm.sh: isAnalog: true 
I/qcom-fm (  722): /system/etc/init.qcom.fm.sh: Transport :  
I/qcom-fm (  723): /system/etc/init.qcom.fm.sh: Version : 67240453 
I/qcom-fm (  724): /system/etc/init.qcom.fm.sh: default transport case  
E/GeckoConsole(  109): Content JS INFO at app://system.gaiamobile.org/js/window_manager.js:1115 in createFrame: %%%%% Launching Phone as remote (OOP)
I/Gecko   (  681): ###################################### forms.js loaded
I/qcom-fm (  734): /system/etc/init.qcom.fm.sh: FM QSoC calibration and firmware download succeeded 
I/qcom-fm (  743): /system/etc/init.qcom.fm.sh: In FM shell Script 
I/qcom-fm (  744): /system/etc/init.qcom.fm.sh: mode: config_dac 
I/qcom-fm (  745): /system/etc/init.qcom.fm.sh: isAnalog: true 
I/qcom-fm (  746): /system/etc/init.qcom.fm.sh: Transport :  
I/qcom-fm (  747): /system/etc/init.qcom.fm.sh: Version : 67240453 
I/qcom-fm (  749): /system/etc/init.qcom.fm.sh: FM QSoC calibration and firmware download succeeded 
E/profiler(  736): Registering start signal
E/GeckoConsole(  518): Content JS LOG at app://fm.gaiamobile.org/js/fm.js:142 in updatePowerUI: Power status: on
E/GeckoConsole(  736): [JavaScript Warning: "Unknown property '-moz-align-self'.  Declaration dropped." {file: "resource://gre-resources/ua.css" line: 44}]
I/FMRadio (  109): Antenna state is changed!
W/AudioFlinger(  117): Thread AudioOut_1 cannot connect to the power manager service
W/AudioHardwareMSM76XXA(  117): rpc_snd_set_device(27, 0, 0)
W/AudioHardwareMSM76XXA(  117): rpc_snd_set_device(6, 1, 0)
E/GeckoConsole(  518): Content JS LOG at app://fm.gaiamobile.org/js/fm.js:142 in updatePowerUI: Power status: off
(In reply to Parul Mathur from comment #4)

[snip]

Parul the description you gave is Bug 830657.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 830657

Updated

5 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.