Setting the width of a flexbox's child to 100%, using javascript, makes this item to use its max content width instead of the available parent width

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: doyer.guyllaume, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 702715 [details]
flexbox_bug_firefox_width_100prct.htm

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.52 Safari/537.17

Steps to reproduce:

Created a 2 levels flexbox layout, adding 2 elements in a flexible box (direction column) and apply some background colors to see rendered blocs dimensions.
Setting the width of one child of to 100%, afterwards via javascript.

The bug can be seen here : http://fiddle.jshell.net/gudoy/hGLtg/show/

In my test case, strangely it does not seem to occur on every page load. However Refreshing the page several times should show hime.


Actual results:

The item no longer use the whole available size (parent width) as it does width the '100%' but uses instead it's max content width.


Expected results:

Adding the width 100% shouldn't have any effect. This works expectedly in Chrome, Opera 12 and IE 10
What about using new profile or in safe mode ?

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
(Reporter)

Comment 2

6 years ago
It does not change anything. I can still reproduce the bug.
Guyllaume can you still reproduce this in the newest Firefox versions?
Flags: needinfo?(doyer.guyllaume)
(Reporter)

Comment 4

5 years ago
Trying with Firefox 22, this seems to be fixed.
Flags: needinfo?(doyer.guyllaume)
I'll close this as WORKSFORME.
Please feel free to reopen it, if the something changes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.