[music][metadata] Albums of the same name will be combined even though they have different artists

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
7 years ago
Last year

People

(Reporter: nhirata, Assigned: pdahiya)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/f2460bf17811
Gaia   7258384661345ded5a8813c34774ef8a0b56cc02
BuildID 20130114230201
Version 18.0
Otoro

## Repro :
1. put on the sdcard : 2 different songs that are from two different artists that have the album of Untitled

## Expected :
1. two separate Untitled Albums

## Actual :
1. They are on the same in the Album view

## Note :
1. Not sure if this was intentional or not...
Let's see what UX want, Casey, can you please comment this? thanks.
Flags: needinfo?(kyee)

Comment 2

7 years ago
Are we referring to the abstract art that is used in place for music without any associated album art?   I would be nice to have the artwork randomized so that the user doesn't confuse the two songs being from the same artist or album.  Not a showstopper but should be fixed.
Flags: needinfo?(kyee)
https://hg.mozilla.org/mozilla-central/rev/783ea1637777
Assignee: nobody → benjamin
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Looks like that bug number got typoed in the commit...
Assignee: benjamin → nobody
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee

Comment 5

6 years ago
Casey,
I started looking at this bug. Had a followup question:
1. Do we today show a fixed artwork for any untitled song which does not have associated art? And how is this fixed artwork picked for such untitled songs. As in do we have a pool of fixed artwork images, which we cycle through as the Music app is loading the list of untitled songs.

I am in PST timezone, if we need to discuss over irc my irc is: pdahiya
Flags: needinfo?(kyee)

Comment 6

6 years ago
Hi Punam,
Yes, we have a pool of artwork that we use for music that does not have any associated artwork.

In terms of how this artwork is picked, ideally the initial pick should be random.  

Once picked, the artwork should stick with that music.  If for example, I upload the song "Yellow Submarine" to my phone and I get the magenta colored generic artwork, the next time I access that song, I should get the same artwork.    

The idea here is that users will associate that artwork for any given song.  Changing the artwork may confuse some users.

If this is at all too complex, a random drawn image will suffice.


A note for visual design:
Having multiple random artwork may be more trouble than it's worth because of the logic as described above.   

I often find myself confuse the abstract album art for real album art.   We should probably go with something that can't be mistaken for real album art.
Flags: needinfo?(kyee) → needinfo?(padamczyk)
Its possible its a bit too extreme, I would like to tone it down a bit and have the album and art name dynamically written onto the cover (remove the artist / album overlay in the music player). 

David Flanagan wants to see some music player code improvements, and we do want to add more logic to the mix page... so perhaps this would be another great addition to a v.2 of the player.
Flags: needinfo?(padamczyk)
Does this happen for other albums that have the same name but different artists? I noticed that Google Play Music has that bug, I have a few "Greatest Hits" albums that all get lumped together.

RE: Album art, Google Play Music has a generic image for that:
http://ssl.gstatic.com/music/fe/f686c49f5a6f525fb5a84a4fe965040b/default_album_art_big_card.png

iTunes just draws a gray box with a large centered "♫" in it for albums without cover art.
Assignee

Comment 9

6 years ago
The current experience on unagi combines the songs with same album name even if they have different artists. So if you have songs from two separate "Greatest Hits" album, with different artists, it's showing under the same "Greatest Hits" album in album view.
Assignee

Updated

6 years ago
Assignee: nobody → pdahiya
Assignee

Comment 10

6 years ago
Going over the original description of the bug https://bugzilla.mozilla.org/show_bug.cgi?id=831248#c0 and the expected behavior mentioned there in, If i have  10 songs each of which has an artist name associated but does not have album name associated then according to expected behavior, we will end up showing 10 untitled albums, each of those untitled albums having just one song each.

I propose we do a 2 part fix:
1. Hide Untitled Album songs in Album tab and Untitled Artist songs in Artist tab. This is very similar to what Apple does in iPhone music app. attaching the proposed PR fix.
2. Secondly, similar to what Ted alludes to in comment #8, for scenarios where there is a same album name and different artist names associated with songs, we create composite indexes so that Album tab shows records for (album name + artist name) as unique.

The second part is more involved.

attaching the screenshots for Part 1 of the fix.
Casey, your thoughts?
Flags: needinfo?(kyee)

Comment 13

6 years ago
Reassigning needinfo from Casey to Rob since media is Rob's domain.
Flags: needinfo?(kyee) → needinfo?(rmacdonald)
Attachment mime type: text/plain → text/x-github-pull-request
After reviewing Punam's proposal with Rob, we agreed that this solution should work well for untitled albums and artists. 

I just want to clarify for part 1. that the songs with untitled albums and artists should still appear in the songs list. Also, if the user creates a name for an untitled album, it should then appear in the albums list with the new name.
Flags: needinfo?(rmacdonald)

Updated

4 years ago
Summary: [Music] Untitled Albums will be combined even though they have various artists that aren't the same. → [music][metadata] Untitled Albums will be combined even though they have various artists that aren't the same.

Updated

4 years ago
Summary: [music][metadata] Untitled Albums will be combined even though they have various artists that aren't the same. → [music][metadata] Albums of the same name will be combined even though they have different artists
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 7 years agoLast year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.