Moz Activity - new mail - can't attach images

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: evyatar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

The 'new' moz activity (mail) doesn't allow sending attachments.

It seems like there are two activities- share (which is for sharing images) and new (which is for sending new emails)- but you can't combine their data, so you can create a new mail with attachments.

ideally it would look like this:
MozActivity({
 'name': 'new',
 'data': {
  'type': 'mail',
  'URI': mailURL,
  'blobs/filenames': [...]
 }
})


affects Notes app
https://marketplace.firefox.com/reviewers/apps/review/notes

Updated

6 years ago
Blocks: 815411

Updated

6 years ago
No longer blocks: 815411

Updated

6 years ago
Blocks: 866244
This bug seems reported long time ago. Still a problem? If my recall is right, bug 782766 should already support passing blob for activities.
The bug is that the only way to get an attachment onto an email that is being composed is via the 'share' activity and we our filter on type is "image/*" which limits what can be attached.

I think we were playing it safe on that constraint.  Videos have a good chance of bouncing depending on e-mail size limits, and we wouldn't understand how to share things that aren't blobs if we do that.  I guess I can't find a way to share a URL right now?

Updated

6 years ago
No longer blocks: 866244
Duplicate of this bug: 866244
It seems our sharing restrictions have been lifted significantly, and you can also use a share activity to create an email with an attachment now. I can't think of anything further actionable here, so I think we should close this. Please re-open or file a new bug if there is still some unexpected behavior.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.