Inspector changes <animateTransform> to (invalid) <animatetransform> in XML view of an SVG document

RESOLVED DUPLICATE of bug 1248381

Status

DevTools
Inspector
P2
normal
RESOLVED DUPLICATE of bug 1248381
6 years ago
8 days ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
STR:
 1. Load https://hg.mozilla.org/mozilla-central/raw-file/8d8912467c41/browser/devtools/profiler/cleopatra/images/throbber.svg
 (or any SVG file that has an <animateTransform> element)

 2. Right-click the SVG, and choose "Inspect Element"
 3. In the Inspector XML view (on the left), toggle the arrows to fully expand all elements.
 4. Look for <animateTransform>

ACTUAL RESULTS: Inspector represents the <animateTransform> tag with <animatetransform>
(lower-case "T"), which is invalid SVG.



SIMPLER STR:
 1. Enter data:image/svg+xml,<someTag/> into your URL bar.
 2. Right-click "<someTag/>" in the resulting XML view and pick "Inspect Element"

ACTUAL RESULTS: Inspector converts the tag to "sometag" (lowercase T)

Comment 1

6 years ago
Urgh.
Priority: -- → P2

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1248381

Updated

8 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.