SSL Error on www.psprint.com due incorrectly configured server (missing intermediate certificate)

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
6 years ago
6 years ago

People

(Reporter: watch, Unassigned)

Tracking

17 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C; MS-RTC EA 2; MS-RTC LM 8)

Steps to reproduce:

opened FF and printed my url 


Actual results:

I get an SSL error in FF but no issues in other browsers including older version of FF.


Expected results:

I have a vaild Global sign certificate, it should error.
(Reporter)

Updated

6 years ago
Severity: normal → blocker
Please provide the exact URL with the SSL error and post the technical details of the error page.
Severity: blocker → normal
Flags: needinfo?(watch)
(Reporter)

Comment 2

6 years ago
https://www.psprint.com
Flags: needinfo?(watch)
(Reporter)

Comment 3

6 years ago
Created attachment 702994 [details]
Screen shot of the SSL error
Is that your site ?
The site is incorrectly configured and doesn't send an intermediate certificate.
You get this error only if your Firefox user profile doesn't have a cached copy (from another page with correct setup) of the intermediate certificate.

This can be easy checked with http://www.sslshopper.com/ssl-checker.html#hostname=https://www.psprint.com/
(Reporter)

Comment 5

6 years ago
Thanks for the updates!

The website is one of our partners.

Do you think the issue is with the intermidate certificate?
The server doesn't send the intermediate certificate as it have to.
The root certificate in Firefox can not build a chain to the certificate send by the server without the intermediate certificate and that means that get a security error in Firefox.

You will not get a security error in Firefox if you visit once a different site that is using the same certificate from GlobalSign and that sends the intermediate certificate correctly. The intermediate certificate will be cached in the Firefox user profile and you can access https://www.psprint.com without getting a SSL error. I tell you that only because someone may tell you that it works for them with the same Firefox version or why it works in IE (chrome is using IEs Certificate root store)

The website owner should contact the GlobalSign support in case that he doesn't know how to fix it. The SSLshopper test page from comment#4 includes a link that explains how to fix the issue.

Will you contact the owner of www.psprint.com or should I try my luck ?
It might be better that you will do it if it's a partner.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Summary: Firefox 17.0.1, i get SSL error on this version of FF. where other broswers IE, chrome and safari has no issues. Also older version of FF did not have any issue. → SSL Error on www.psprint.com due incorrectly configured server (missing intermediate certificate)
(Reporter)

Comment 7

6 years ago
Thanks for the updates,we will contact global sign and dix the issue.
(Reporter)

Comment 8

6 years ago
Thank you very much for all your help yesterday. Worked with Global Sign and resolved the issue.
Resolution: INVALID → WORKSFORME
The server is fixed according to http://www.sslshopper.com/ssl-checker.html#hostname=psprint.com
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.