Fullscreen video playback leaves occluded image layer in the layer tree

VERIFIED FIXED

Status

Firefox OS
Gaia::Video
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: cjones, Assigned: cjones)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.0 fixed)

Details

Attachments

(1 attachment)

Not 100% clear if this is a gecko bug, but for v1 gaia "fix" is easiest.  This stray occluded image layer causes us to fall off our fast composition path.

Blocks a blocker.
Created attachment 703014 [details] [diff] [review]
Hide the thumbnail view when the player is active
Attachment #703014 - Flags: review?(dflanagan)
Comment on attachment 703014 [details] [diff] [review]
Hide the thumbnail view when the player is active

Review of attachment 703014 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with the change described below.

::: apps/video/js/video.js
@@ +525,5 @@
>  
>    dom.player.pause();
>    dom.deleteVideoButton.classList.add('hidden');
>  
> +  dom.thumbnails.classList.remove('hidden');

It turns out that if you put this line here, then there is a period of about a second where the video is still displayed but events are going to the thumbanails. If you wait 'till the progress bar shows that the video is at the end and tap on the screen, your tap will end up starting a new video playing.

Move the line above into the completeHidingPlayer() function below to make it work right.

(The delay is the video app taking a new screenshot to use as a thumbnail. It does this so if you stop in the middle of a video, it can show you where you left off in the thumbnail list.)
Attachment #703014 - Flags: review?(dflanagan) → review+
Cc'ing Dale so he knows why this change was made in his app.
Landed: 
https://github.com/mozilla-b2g/gaia/commit/a22cbf339f0d38ef7d533b1110029c19b087dff4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-b2g18: --- → fixed
Landed on mozilla-b2g18/gaia master prior to the 1/25 branching to mozilla-b2g18_v1_0_0/v1.0.0, updating status-b2g-v1.0.0 to fixed.
status-b2g18-v1.0.0: --- → fixed

Comment 6

5 years ago
Unagi Build ID: 20130313070202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/e74dafa6b2d9
Gaia: b34e726147f8e671ad8c538b50900ccfbffcb084
Kernel: Dec 5th

Does not Reproduce the delay does not occur.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.