Emails are being generated with incorrect OrangeFactor of 0.0

RESOLVED WONTFIX

Status

Tree Management
OrangeFactor
RESOLVED WONTFIX
6 years ago
4 years ago

People

(Reporter: mcote, Unassigned)

Tracking

({sheriffing-P3})

Trunk
sheriffing-P3

Details

(Reporter)

Description

6 years ago
For some reason, woo_mailer.py sometimes fails to correctly calculate this week's OF, instead coming up with an orange count of 0 and thus an OF of 0.0.  We are suppressing those emails now thanks to bug 827856, but we should find the root cause.
(Reporter)

Comment 1

5 years ago
We also saw an incorrect OF of 0.1 one week, which caused us to raise the threshold to 2 in bug 854907.  I'll look more closely at this soon.
Keywords: sheriffing-P3
(Assignee)

Updated

4 years ago
Product: Testing → Tree Management
Wontfix in favour of OrangeFactor v2 which will consume Treeherder's API, and likely be written from scratch.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.