Open Bug 831499 Opened 7 years ago Updated 6 years ago

versionbump.py should give difference from in-tree version from pypi version

Categories

(Testing :: Mozbase, defect)

defect
Not set

Tracking

(Not tracked)

REOPENED

People

(Reporter: k0scist, Unassigned)

References

Details

Short of downloading the code and painstaking hand comparison the way
to see the difference (if any) between the latest pypi version and the
version in the tree is:

- go to pypi and find the latest version
- run a `git diff` based on the tag from the latest version filtering
  such that you only see the changes to the package of interest

This can all be automated! :)

Why we care: let's say i don't know if, say, mozinfo-0.123 has any
outstanding changes that possibly need mirroring to pypi for possibly
some other package.  Currently, people won't do the crazy manual steps
above and possibly break things.  We should make it easy so that
people don't break things.  In a further future, the script could
check to ensure that dependencies are up-to-date to avoid clashes
between releases and in-tree code.
versionbump.py no longer exists after bug 949600.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
I don't think we should get this bug closed. Instead get it ported via bug 974184 for hg.m.o.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Agreed, but this will happen in bug 974184 now; duping there.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 974184
No longer depends on: 926400
Status: RESOLVED → REOPENED
Depends on: 974184
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.