Homescreen icons created w/ Browser 'star' icon & everything.me can't be removed

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

({b2g-testdriver, regression, unagi})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
STR:
 1. Visit any page in the browser
 2. Tap the "star" in lower-right
 3. Choose "Add to home screen"
 4. Be sure you've got a name & URL in the resulting dialog, and tap "Add to Home Screen"
 5. Now, hit Home button to go to home screen, and pan to the screen with your just-added icon.
 6. Hold down any icon to enter "jiggly" mode.
 7. Tap the red "x" on the icon that you've just added.
   --> A removal dialog appears
 8. Tap "Remove" in the dialog

EXPECTED RESULTS: Icon should be removed
ACTUAL RESULTS: Icon is still there.


Build ID: 20130114070200

Pretty sure this used to work --> marking as "regression"
(Reporter)

Comment 1

6 years ago
(In reply to Daniel Holbert [:dholbert] from comment #0)
>    --> A removal dialog appears
>  8. Tap "Remove" in the dialog

(BTW: that dialog has 2 buttons, [Cancel] and [Remove]. Neither one has any visible effect, other than dismissing the dialog.)

This also affects apps installed via everything.me.

It doesn't affect apps that I've installed through the Marketplace, though -- those pop up a different dialog (saying $APP and all of its data will be deleted"), a
Summary: Homescreen icons for browser-bookmarks can't be removed → Homescreen icons created w/ Browser 'star' icon & everything.me can't be removed
(Reporter)

Comment 2

6 years ago
(In reply to Daniel Holbert [:dholbert] from comment #1)
> It doesn't affect apps that I've installed through the Marketplace, though
> -- those pop up a different dialog (saying $APP and all of its data will be
> deleted"), a

...and the "Delete" button in *that* dialog does seem to work.
(Reporter)

Updated

6 years ago
tracking-b2g18: --- → ?
tracking-firefox18: ? → ---
Something tells me you are on an old build. In the current build, add to the homescreen doesn't even work (known bug).
Yeah, this bug I believe was fixed. But right now, you can't even add a bookmark to the homescreen.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

6 years ago
I'm on the build that was released on "beta" dogfooding channel yesterday afternoon, w/ build ID 20130114070200, and "check for updates" says there's nothing new.

I'm assuming the changes you're describing (and the "you can't even add a bookmark to the homescreen" issue) haven't made it to Beta channel yet, because I can add a bookmark to the homescreen just fine.
blocking-b2g: tef? → ---
tracking-b2g18: ? → ---
I was fixed here #830024
You need to log in before you can comment on or make changes to this bug.