Browser crashes when trying to load html parameter test on mac

VERIFIED FIXED in mozilla0.9.4

Status

()

Core
Plug-ins
P1
critical
VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: shrirang khanzode, Assigned: Peter Lubczynski)

Tracking

({topcrash})

Trunk
mozilla0.9.4
PowerPC
Mac System 9.x
topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
win 0529

Tests on this page do not load flash movies. Only text loads.
(Reporter)

Comment 1

17 years ago
ok, just tested on mac 0529 and this does crash trying to load the above page. 
Changing sunnary, OS.stack trace coming....
OS: Windows NT → Mac System 9.x
Summary: flash movies don't load from HTML parameter test suite → Browser crashes load from HTML parameter test suite
(Reporter)

Comment 2

17 years ago
stack :
Call Stack:    (Signature = 0x7c0802a4 a3e922e1) 
     
   0x7c0802a4 
                                    
     
   nsPluginInstanceOwner::Paint() 
                                   [nsObjectFrame.cpp, line 2856]
     
   nsObjectFrame::Paint() 
                                   [nsObjectFrame.cpp, line 1350]
     
   PresShell::Paint() 
                                   [nsPresShell.cpp, line 5245]
     
   VIEW_DLL + 0x6d6c (0x1575372c) 
                                    
     
   VIEW_DLL + 0x16394 (0x15762d54) 
                                    
     
   VIEW_DLL + 0x16100 (0x15762ac0) 
                                    
     
   VIEW_DLL + 0x14c3c (0x157615fc) 
                                    
     
   VIEW_DLL + 0x17d04 (0x157646c4) 
                                    
     
   VIEW_DLL + 0x6510 (0x15752ed0) 
                                    
     
   nsWindow::DispatchEvent() 
                                   [nsWindow.cpp, line 1959]
     
   nsWindow::DispatchWindowEvent() 
                                   [nsWindow.cpp, line 1980]
     
   nsWindow::UpdateWidget() 
                                   [nsWindow.cpp, line 1631]
Summary: Browser crashes load from HTML parameter test suite → Browser crashes when trying to load html parameter test on mac

Updated

17 years ago
Severity: normal → critical
Keywords: crash

Comment 3

17 years ago
I'm not seeing this on Win2K. Moving to m0.9.3.
Target Milestone: --- → mozilla0.9.3

Comment 4

17 years ago
Changing platform
Hardware: PC → Macintosh
(Assignee)

Comment 5

17 years ago
Shrirang,
Is this still happening? I haven't seen it on talkback. adding qawanted.

Anyway, I'm probably not going to get to this today, so moving to mozilla0.9.4
Status: NEW → ASSIGNED
Keywords: qawanted
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 6

17 years ago
This is currently on the top crash list for NS 6.1 Mac. Talkback incident is
33903022. URL http://www.whirlgirl.com/html/index.html

The problem is that when nsPluginInstanceOwner::CreateWidget() gets called to
create the plugin widget, the nsObjectFrame already has a nsIView. This causes
it to skip the code which allocates the plugin widget. This causes it to crash
in nsPluginInstanceOwner::Paint() when it calls GetWidgetPositionAndClip() which
relies on mWidget being vaild. Peter believes this is due to the use of
"document.write" to create the plugin (Flash in this case) instance.
Keywords: crash → nsenterprise, topcrash
(Assignee)

Comment 7

17 years ago
I think replacing that code in Paint() with a call to FixUpPluginWindow() may work.
(Assignee)

Comment 8

17 years ago
Created attachment 46219 [details] [diff] [review]
patch to fix crash, v.1
(Assignee)

Comment 9

17 years ago
This patch cleans things up a bit by having Paint() also go through
FixUpPluginWindow() and therefore prevent the crash. I'm seeking reviews.
Keywords: patch
Priority: -- → P1
Whiteboard: [seeking reviews]
(Assignee)

Comment 10

17 years ago
Note: The testcase still does not work (on ANY platform) due to STYLE="POSITION:
relative;" on the EMBED. I think this is bug 71813.

Comment 11

17 years ago
Not that I disagree with the patch (I've thought about suggesting the same thing
a dozen times), but it will simply eliminate the crash by never determining
where the object should be placed. I'm not sure that's the right approach here.
Can the plugin even work without mWidget being valid?
(Assignee)

Comment 12

17 years ago
Created attachment 46239 [details] [diff] [review]
much better patch (making testcase work) v.2
(Assignee)

Comment 13

17 years ago
I think that last patch fixes the root of the problem with mWidget as Brian
described.

Comment 14

17 years ago
Yes, much better. Let's land this ASAP.
r=bnesse.

Comment 15

17 years ago
sr=waterson
(Assignee)

Updated

17 years ago
Keywords: review
Whiteboard: [seeking reviews]
(Assignee)

Comment 16

17 years ago
Patch checked into the trunk, marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 17

17 years ago
yeah..verif fixed on trunk 0821. no crash.
Status: RESOLVED → VERIFIED

Comment 18

17 years ago
per eclient triage removing nsenterprise keyword
Keywords: nsenterprise
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.