Story - Be prompted to restore Firefox as default browser

VERIFIED FIXED

Status

P4
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: asa, Unassigned)

Tracking

Details

(Whiteboard: feature=story c=Install_and_setup u=browser_user p=0 status=verified)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 703108 [details]
UC-1-8 	 Be prompted to restore Firefox as default browser

Updated

6 years ago
Priority: -- → P1

Updated

6 years ago
Priority: P1 → P2

Updated

6 years ago
Whiteboard: c=Install_and_setup u= p= → feature=story status=for_testing c=Install_and_setup u=browser_user p=0

Updated

6 years ago
Priority: P2 → P5
(Reporter)

Updated

6 years ago
Summary: Be prompted to restore Firefox as default browser → Story – Be prompted to restore Firefox as default browser

Updated

6 years ago
Priority: P5 → P4

Updated

6 years ago
Blocks: 838081
Are we getting rid of the modal prompt here and replacing with the start page? Is there anything that has to be done here Yuan? Thanks!

Updated

6 years ago
Whiteboard: feature=story status=for_testing c=Install_and_setup u=browser_user p=0 → feature=story c=Install_and_setup u=browser_user p=0

Updated

6 years ago
Blocks: 841997
No longer blocks: 838081

Comment 2

6 years ago
Needs clarification, see comment 1. If we want to stick with the default prompt, this is WFM. If we want a new in content page, this should be moved over to Firefox / Theme and we'll need to find someone who wants to work on it.
Flags: needinfo?(asa)
I think the incontent page is a nicer experience. But I don't know if converting to that is a v1 requirement.
(Reporter)

Comment 4

6 years ago
In content page is no longer a v1 feature. We'll live with the dialog for now.
Flags: needinfo?(asa)
(Reporter)

Updated

6 years ago
Summary: Story – Be prompted to restore Firefox as default browser → Story - Be prompted to restore Firefox as default browser
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: unspecified → ---

Updated

6 years ago
Blocks: 839143
No longer blocks: 841997

Updated

6 years ago
Flags: needinfo?(jbecerra)
QA Contact: jbecerra
Tested on 2013-03-05 on Nightly built from: http://hg.mozilla.org/mozilla-central/rev/015da7030aab
- Verified using fist admin account, following the story. All main success scenarios looked ok.
- Tested using an account created with the first admin account, and went through the same steps, but there is no tile in the Start screen. That was filed in bug 847602.

I'm verifying this because the happy path as described in the story works.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jbecerra)
Whiteboard: feature=story c=Install_and_setup u=browser_user p=0 → feature=story c=Install_and_setup u=browser_user p=0 status=verified

Updated

6 years ago
Blocks: 841099
No longer blocks: 839143
Depends on: 856904
Re-verfied for it4 testing as per steps in Comment 5 and everything passes without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-04-01-03-08-17-mozilla-central/

Also went through the following extra steps:

- Selected "Make Nightly the default browser" through the "Advanced Settings"

As Juan mentioned in Comment 5, Bug 847602 is still occurring. I've also created another Change Story issue related to the tile not appearing once it has been unpinned. Attached the issue to this ticket.
Went through the following "Story" for iteration #8 testing without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-12-03-11-38-mozilla-central/

- Went through the original "Story" that has been attached without any issues
- Went through the test cases that have been added in Comment 5
- Went through the test cases that have been added in Comment 6

Note:

- Bug 847602 is still an issue, reproduced several times.
User Agent:Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:25.0) Gecko/20130702 Firefox/25.0
Build ID:20130702110300

Tested on latest nightly from
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013/07/2013-07-02-11-03-00-mozilla-central/

When I installed new latest nightly Firefox, It didn't give me prompt to set default browser.I followed user story attached here.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Hi Samvedana, I'm filing a separate Defect Story with the issue you found and relating it back to this feature.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Depends on: 889687
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130809030203
Built from http://hg.mozilla.org/mozilla-central/rev/e33c2011643e

Didn't WFM
Tested on windows 8 using latest nightly for iteration-11.Please see bug 889687.
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130819030205
Built from http://hg.mozilla.org/mozilla-central/rev/c8c9bd74cc40

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in user story and got expected result.
Status: RESOLVED → VERIFIED

Updated

5 years ago
No longer depends on: 856904
You need to log in before you can comment on or make changes to this bug.