Proxy configuration script fails to install

RESOLVED FIXED

Status

()

Firefox
Untriaged
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Frank, Unassigned)

Tracking

18 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232

Steps to reproduce:

Firefox version 18.0 does not load the Proxy Configuration script. Whether “Auto-detect proxy settings for this network”, or “Automatic proxy configuration URL:” is used. Error console window shows the error message: "PAC file failed to install from http://wpad/wpad.dat". IE and Google Chrome successfully retrieve and execute the proxy configuration script using the same URL.

I tried reinstalling (including removing all preferences), and rebooting.

I have tried this on Windows 7 (64-bit), Windows XP SP3 (32-bit), and LinuxMint 12 (64-bit). All have failed with the same error. On LinuxMint 12, I also tried a local file copy.

Firefox version 17.0.1 is the latest version I've tried that works on the same platforms.

I maintain our company's proxy.pac (wpad.dat) file, and have been since Netscape 2.0. So, I'm fairly familiar with these settings in our environment.




Actual results:

Firefox returns an error web page similar to:

Unable to connect
Firefox can't establish a connection to the server at 
www.linuxmint.com.




Expected results:

The intended Internet web site would be retrieved through the configured proxy.
This looks like a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 828202
Thanks for the detailed bug report, also! I should have mentioned in addition to marking this a duplicate -- this is likely to be fixed in an 18.0.1 release.
:lizzard, thanks for the triage, but this isn't a dup of 828202 (though it likely is a dup of something that has been fixed in the post-18 timeframe) - 828202 bugs generally deal with file:// uris to get to the pac..this is using http

Frank, can you confirm that a build from ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/18.0.1-candidates/build1/ fixes your problem? 

(are you using myIPAddress() outside of the scope of FindProxyForURL() by any chance - that's a different fixed bug.)

If it doesn't work we'll need to see the contents of the pac file, which can either be attached here or mailed to me at pmcmanus@mozilla.com
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

5 years ago
:mcmanus, thank you for distinguishing this bug, and your help with it.

I just tried Firefox 18.0.1 for Win32 on Windows 7 (64-bit), and it worked right off. Setting was Auto-detect, and tried specific URLs, which worked in each case. I also tried a diagnostic variant (sends alert messages to error log), and demonstrated that the proxy.pac was indeed being executed.

I don't have time at the moment to try it on other platforms (Win XP or Ubuntu/Mint).

I do not use myIPAddress() as it is ambiguous on some platforms. I also don't use any functions that do DNS queries. Er, correction, I do call myIPAddress, but just to display the value in the diagnostic info. The diagnostic message shows a valid client IP address. I use shExpMatch and isPlainHostName functions in the script.

:lizzard, thank you to quick attention to this as well.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.