[l10n][pt-BR] The Apps Selection UI in the Settings App is using app names in English, even though there are pt-BR app name translations available - fixed by app restart

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g18+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Build: B2G 18 1/16
Device: Unagi

Steps:

1. Change the language to pt-BR
2. Check the homescreen to verify that the browser app has a translation
3. Check that same app in the apps perms UI

Expected:

The name for the browser app should be consistent - pt-BR on the homescreen, pt-BR in the apps perm UI.

Actual:

The name for the browser app is pt-BR on the homescreen, but it's English in the apps perm UI. Same issue for the camera app. Sounds like we have a translation here available for pt-BR, but it isn't being used on the apps perm UI.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → tef?
(Reporter)

Comment 1

5 years ago
Created attachment 703122 [details]
Homescreen - Notice the Browser Has a pt-BR Translation
(Reporter)

Comment 2

5 years ago
Created attachment 703123 [details]
Apps Perms UI - Notice the Browser App is Not Translated
If you restart the app. then the app list will be localized.
The root cause is in onLocalized() function, defined in settings/js/utils.js [1]

Because apps permission page is lazily loaded, so in that function, the callback will be invoked directly without register the callback as 'localized' event handler.

[1] https://github.com/mozilla-b2g/gaia/blob/50f0fd737d743d30a89a1f5e3362d617cfcd8ad7/apps/settings/js/utils.js#L274
Assignee: nobody → rlu
(Reporter)

Comment 4

5 years ago
If it's fixable by restart, probably not going to block.

The blocking factor I think originally was if the translation never happened at all.

We should track this though.
blocking-b2g: tef? → ---
tracking-b2g18: --- → ?
(Reporter)

Updated

5 years ago
Summary: [l10n][pt-BR] The Apps Selection UI in the Settings App is using app names in English, even though there are pt-BR app name translations available → [l10n][pt-BR] The Apps Selection UI in the Settings App is using app names in English, even though there are pt-BR app name translations available - fixed by app restart
Can you check Jason if you had the app closed prior to changing the language or if the app was open prior to changing the language?

I think it's not checking the settings change for the language for it to switch if the app is already open.  In which case, I think it's related to a bug... but I can't seem to find it at this moment in time...
(Reporter)

Comment 7

5 years ago
(In reply to Naoki Hirata :nhirata from comment #5)
> Can you check Jason if you had the app closed prior to changing the language
> or if the app was open prior to changing the language?
> 
> I think it's not checking the settings change for the language for it to
> switch if the app is already open.  In which case, I think it's related to a
> bug... but I can't seem to find it at this moment in time...

It's the same style of issue as bug 836812. I had the app open when I changed the language.
tracking-b2g18: ? → +
This bug is still valid. We should backlog this mini-improvement.
Assignee: rlu → nobody
blocking-b2g: --- → backlog

Comment 9

4 years ago
Since App permission panel is refactored I can't reproduce this issue.

set qawanted to help us reconfirm it's been resolved.
Keywords: qawanted
Issue is NOT reproducible on Buri 2.0, and Flame 2.1.

My STR and observed behavior:
1) Launch Browser and browse to a website.
2) Launch Settings app > Language > change it to 'Português (do Brasil)'
3) Return to Homescreen and observe Browser app name

- Browser name is changed to 'Navegador'

4) Go to Configurações > Aplicativos, and observe Browser app name

- Browser name is changed to 'Navegador'


Tested on:
Device: Buri 2.0
BuildID: 20140814223216
Gaia: 295c7f50707372e5af6d8e83148d2d970076dfd6
Gecko: 879c5208084f
Version: 32.0 (2.0)
Firmware v1.2device.cfg
User Agent Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 2.1 Master
BuildID: 20140814191916
Gaia: 9979fccc6321be72cd17370f3a20c65bc376af33
Gecko: c9f8cc9ce89c
Version: 34.0a1 (2.1 Master)
Firmware V123
User Agent Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
Resolving as Works-For-Me because of results in Comment 10
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Resolution: --- → WORKSFORME
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.