Closed Bug 831637 Opened 7 years ago Closed 2 years ago

B2G RIL: Each parcel request must has a callback

Categories

(Firefox OS Graveyard :: RIL, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:backlog)

RESOLVED WONTFIX
tracking-b2g backlog

People

(Reporter: kk1fff, Unassigned)

References

Details

Attachments

(2 files, 1 obsolete file)

Currently, we make parcel requests but cannot always specify the function that handles the result, as most requests don't support callback. We should make all the requests support callback.
Depends on: 835186
Assignee: nobody → pwang
Assignee: pwang → vyang
Duplicate of this bug: 910539
Component: DOM: Device Interfaces → RIL
Product: Core → Boot2Gecko
[Tracking Requested - why for this release]:
If you don't mind, I would like to continue this work.
Assignee: vicamo → echen
Depends on: 991582
Attachment #708506 - Attachment is obsolete: true
Depends on: 999300
Depends on: 1159591
Unassigning myself as I am no longer working on this.
Assignee: echen → nobody
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.