[Keyboard] Long press on keyboard doesn't trigger focus on special characters list

RESOLVED WORKSFORME

Status

Testing
Marionette
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: ypwalter, Unassigned)

Tracking

({helpwanted})

unspecified
ARM
Gonk (Firefox OS)
helpwanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(b2g18+ affected)

Details

(Reporter)

Description

5 years ago
If you do long press on a key something like "a", the list would come out. However, it won't focus on the first special character. After release the long press, it won't output the special character and will output "a" only.
(Reporter)

Updated

5 years ago
tracking-b2g18: --- → ?
(Reporter)

Updated

5 years ago
Keywords: helpwanted
Is this happening in automation only or can it be triggered by a user - if user-side this seems like terrible input breakage.
Keywords: qawanted
When I try to hold down "a" I get the list pop up, and when I release it selects the first special character for me.  Which is different than comment 0 but still wrong.
(Reporter)

Comment 3

5 years ago
Hi,
I already select this as "Testing - Marionette" category.
This happens in Marionette only, and it can be trigger by the user.
So, Lukas, don't worry about the user side.

Jason, that's by design. You can try to get any kind of other smart phones (Android/iPhone). If you press long enough and don't select anything, it would select the first special character.
(Reporter)

Updated

5 years ago
Keywords: qawanted
QA Contact: wachen
This is due to https://bugzilla.mozilla.org/show_bug.cgi?id=836330, we aren't firing the 'contextmenu' event when we should be. Once a fix lands, we should test this bug.
Depends on: 836330

Comment 5

5 years ago
Issue repros.  When pressing on a button for a couple seconds it should pop up with special characters associated with that letter however no characters show up.  Issue repros on build Id 20130208070201 Dec 5th Kernel
(Reporter)

Updated

5 years ago
Blocks: 831667
Marking tracking so this could be landed without approval until Mar 15, since it's a test-only issue.
status-b2g18: --- → affected
tracking-b2g18: ? → +
(Reporter)

Comment 7

5 years ago
Using action chain is fine now. However, long pressing to get special characters list focus still doesn't work
Quite a few fixes have gone into marionette, and this is now resolved. I tested the keyboard app with:

keys = m.find_elements("class name", "keyboard-key")
a = keys[10] # find letter a
actions = Actions(m)
actions.press(a).wait(5).release().perform()

and the special characters context menu successfully popped up.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
oh and it works with long_press
(Reporter)

Comment 10

5 years ago
It still not working for long_press.
There is no focus on the list comparing to the one using action chains, right?
I'm using the latest b2g-18 build from today and if I do both

keys = m.find_elements("class name", "keyboard-key")
a = keys[10] # find letter a
actions = Actions(m)
actions.press(a).wait(5).release().perform()

and 

keys = m.find_elements("class name", "keyboard-key")
a = keys[10] # find letter a
actions = Actions(m)
actions.long_press(a, 3).perform()

I get the special characters list.

What do you mena by 'focus on the list comparing to the one using action chains'?
You need to log in before you can comment on or make changes to this bug.