Oops error is displayed if Financial and Administrative emails are not entered

RESOLVED DUPLICATE of bug 830965

Status

Marketplace
Payments/Refunds
P2
normal
RESOLVED DUPLICATE of bug 830965
5 years ago
5 years ago

People

(Reporter: Cristian Boldan, Assigned: andym)

Tracking

2013-01-24
x86_64
Windows 7
Points:
---

Details

(Whiteboard: u=patron p=1, URL)

Comment hidden (empty)
(Reporter)

Comment 1

5 years ago
Sorry, accidentally pressed Enter.

Steps to reproduce:
1. Load MP Submissions page https://marketplace-dev.allizom.org/developers/submissions
2. Click on "Compatibility & Payments" link from a paid app
3. Click on "Add or manage payment accounts".
4. Complete all the mandatory fields and leave the Financial Email and Administrative Email fields empty.
5. Click the Register Payment Account button.

Expected results:
Payment account is successfully registered.

Actual results:
Oops error is displayed on top of the form. If we click the "Register Payment Account" without completing any of the fields, it doesn't say that the Financial Email and Administrative Email fields are required.

Notes/Issues:
Verified on FF21 (Win 7).
Screencast for this issue http://screencast.com/t/nsHWq6MKtL
Target Milestone: --- → 2013-01-17
-> andym based on comment 2
Assignee: nobody → amckay
Priority: -- → P2
Whiteboard: u=patron p=1
Target Milestone: 2013-01-17 → 2013-01-24
(Assignee)

Comment 4

5 years ago
Yup dupe. Basta did in this commit:

https://github.com/mozilla/zamboni/commit/8ed26082d9e6d5066a917b4d4ac30121f82af85c
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 830965
You need to log in before you can comment on or make changes to this bug.