Need "about mozilla" in application menu on osx

VERIFIED FIXED

Status

()

Core
XUL
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({platform-parity})

Trunk
PowerPC
Mac OS X
platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
The "About Mozilla" item is missing under the application menu on osx. Patch 
attached to make it display and function. basically just put code from the 
classic menu code dealing with the apple menu back into the carbon version.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: nsmac1, pp
Whiteboard: needs r/sr/a
(Assignee)

Comment 1

17 years ago
Created attachment 36414 [details] [diff] [review]
[patch] create item, make it work
(Assignee)

Comment 2

17 years ago
r=saari

Comment 3

17 years ago
I think this will leak CFStrings

Comment 4

17 years ago
Never mind, going blind.
It looks cool. sr=sfraser

Comment 5

17 years ago
a=tor
(Assignee)

Comment 6

17 years ago
landed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: needs r/sr/a

Comment 7

17 years ago
Seeing as how the "About Mozilla" menu item didn't even function on Mac OS 9 for
a year or two, it's a pleasant surprise to see this squashed so fast. Verified,
6/5 (or whatever) build, 10.0.3.
Status: RESOLVED → VERIFIED

Comment 8

17 years ago
*** Bug 100976 has been marked as a duplicate of this bug. ***

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.