Story - Open Firefox from its app tile

VERIFIED FIXED

Status

Tracking
Metro Operations
P2
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: asa, Assigned: bbondy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=story c=Opening_and_closing u=metro_firefox_user p=3)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 703454 [details]
UC-16 	 Open Firefox from its app tile
(Reporter)

Updated

5 years ago
Priority: -- → P2
(Reporter)

Updated

5 years ago
Whiteboard: c=Opening_and_closing u= p= → c=Opening_and_closing u=metro_firefox_user p=
(Reporter)

Updated

5 years ago
Whiteboard: c=Opening_and_closing u=metro_firefox_user p= → c=Opening_and_closing u=metro_firefox_user p=20
(Reporter)

Updated

5 years ago
Summary: Open Firefox from its app tile → Story – Open Firefox from its app tile
Whiteboard: c=Opening_and_closing u=metro_firefox_user p=20 → c=Opening_and_closing u=metro_firefox_user p=20 feature=story
Depends on: 829127

Updated

5 years ago
OS: Windows 8 → Windows 8 Metro
Whiteboard: c=Opening_and_closing u=metro_firefox_user p=20 feature=story → feature=story c=Opening_and_closing u=metro_firefox_user p=0

Updated

5 years ago
Blocks: 838081

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Whiteboard: feature=story c=Opening_and_closing u=metro_firefox_user p=0 → feature=story c=Opening_and_closing u=metro_firefox_user p=0 status=for_testing
(Assignee)

Comment 1

5 years ago
Reopening for bug 829127
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: feature=story c=Opening_and_closing u=metro_firefox_user p=0 status=for_testing → feature=story c=Opening_and_closing u=metro_firefox_user p=3 status=for_testing

Updated

5 years ago
Whiteboard: feature=story c=Opening_and_closing u=metro_firefox_user p=3 status=for_testing → feature=story c=Opening_and_closing u=metro_firefox_user p=3

Updated

5 years ago
Assignee: nobody → netzen

Updated

5 years ago
Blocks: 837155
No longer blocks: 838081

Updated

5 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 2

5 years ago
Resolving since all dependencies are resolved with bug 829127.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Marco to conduct testing.

Updated

5 years ago
Flags: needinfo?(jbecerra)
The small tile icon looks like the Nightly similar to what is shown when you are asked to pick a default web browser when you install and run Fx for the first time in desktop mode.

You can see this when you gesture up from the bottom of the screen in the Start desktop and click to see All Apps.
Status: RESOLVED → REOPENED
Flags: needinfo?(jbecerra)
Resolution: FIXED → ---

Comment 5

5 years ago
(In reply to juan becerra [:juanb] from comment #4)
> The small tile icon looks like the Nightly similar to what is shown when you
> are asked to pick a default web browser when you install and run Fx for the
> first time in desktop mode.
> 
> You can see this when you gesture up from the bottom of the screen in the
> Start desktop and click to see All Apps.

I think this really falls into bug 735008. We currently only have a basic set of ux resources for shell integration. In fact we're still using the preview tile image on mc.
(Reporter)

Updated

5 years ago
Depends on: 735008
(Reporter)

Comment 6

5 years ago
(In reply to Jim Mathies [:jimm] from comment #5)
> (In reply to juan becerra [:juanb] from comment #4)
> > The small tile icon looks like the Nightly similar to what is shown when you
> > are asked to pick a default web browser when you install and run Fx for the
> > first time in desktop mode.
> > 
> > You can see this when you gesture up from the bottom of the screen in the
> > Start desktop and click to see All Apps.
> 
> I think this really falls into bug 735008. We currently only have a basic
> set of ux resources for shell integration. In fact we're still using the
> preview tile image on mc.

I agree. This story depends on that work so I've made 735008 a work bug blocking this story.
No longer depends on: 735008
(Reporter)

Updated

5 years ago
Depends on: 735008

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

5 years ago
We'll verify this story when we have a build that integrates the work from Bug 735008 - Work - Windows 8 tile and splashscreen resources.
(Reporter)

Comment 8

5 years ago
Verified with 2013-02-22 nightly built from http://hg.mozilla.org/mozilla-central/rev/885cde564ff3
Status: RESOLVED → VERIFIED
(Reporter)

Updated

5 years ago
Summary: Story – Open Firefox from its app tile → Story - Open Firefox from its app tile
(Reporter)

Updated

5 years ago
Depends on: 844954

Updated

5 years ago
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: unspecified → ---
(Reporter)

Updated

5 years ago
Depends on: 841610
(Reporter)

Updated

5 years ago
Depends on: 847602
(Assignee)

Updated

5 years ago
No longer depends on: 841610
Re-verfied for it4 testing and everything passes without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-04-10-06-59-39-mozilla-central/

Double checked the following points:

- Cannot go through Bug 844954 & Bug 829127 as I don't have a device that uses DX9
- Reproduced Bug 847602 (it has has been moved into v2)

Went through the following extra test cases:

- Ensured that the main tile on the "Start" screen matched the icon in the "Windows All Apps" screen
- Installed Firefox on a new user and ensured that both the "Start" tile and the "Windows All Apps" tile appeared correctly
- Ensured that both the "Start" and "Windows All App" tiles appear when upgrading to a newer version of Firefox from an older version
- Ensured that you can re-pin the Firefox Metro tile into the "Start" screen from the "Windows All Apps" screen
Verified for it7.
Went through the following "Story" for iteration #8 testing without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-12-03-11-38-mozilla-central/

- Went through the original "Story" and ensured everything works without any issues
- Went through the comments outlined in Comment 9 and ensured everything worked without any issues
Went through the following "Story" for iteration #9 testing without any issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-27-03-10-27-mozilla-central/

- Went through the original "Story" and ensured everything works without any issues
- Went through the comments outlined in Comment 9 and ensured everything worked without any issues
WFM.

Tested on Windows 8.1 preview for iteration 10 using latest nightly from ftp://ftp.mozilla.org/pub/firefox/nightly/2013/07/2013-07-22-03-02-26-mozilla-central/

I followed user story and got expected result.
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130808030205
Built from http://hg.mozilla.org/mozilla-central/rev/fd4cf30428b0

WFM
Tested on windows 8 using latest nightly for iteration-11. Followed steps provided in user story and got expected result.
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130823030204
Built from http://hg.mozilla.org/mozilla-central/rev/fb2318875cd4

WFM
Tested on windows 8 using latest nightly for iteration-12. Followed steps provided in user story and got expected result.

Updated

4 years ago
No longer depends on: 847602
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.