Closed Bug 831894 Opened 7 years ago Closed 7 years ago

Story - Put Firefox into Snapped View

Categories

(Tracking Graveyard :: Metro Operations, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: asa, Assigned: ally)

References

Details

(Whiteboard: feature=story c=Browser_views u=metro_firefox_user p=3)

Attachments

(1 file)

No description provided.
Blocks: 831678
No longer blocks: 831496
Priority: -- → P2
Whiteboard: c=Browser_views u= p= → c=Browser_views u=metro_firefox_user p=
Whiteboard: c=Browser_views u=metro_firefox_user p= → c=Browser_views u=metro_firefox_user p=5
Assignee: nobody → ally
OS: Windows 8 → Windows 8 Metro
Summary: Put Firefox into snapped view → Story - Put Firefox into Snapped View
Whiteboard: c=Browser_views u=metro_firefox_user p=5 → feature=story status=for_sprint c=Browser_views u=metro_firefox_user p=5
Status: NEW → ASSIGNED
Blocks: metrov1it1
Depends on: 835999, 801000, 829717, 836003, 830505
No longer blocks: metrov1it1
Whiteboard: feature=story status=for_sprint c=Browser_views u=metro_firefox_user p=5 → feature=story c=Browser_views u=metro_firefox_user p=5
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: feature=story c=Browser_views u=metro_firefox_user p=5 → feature=story c=Browser_views u=metro_firefox_user p=0 status=for_testing
Blocks: metrov1legacy
No longer blocks: metrov1backlog
Tested on 2013-02-12 Elm Nightly built from http://hg.mozilla.org/project/elm/rev/aac6ba901fea
- Putting Firefox into snapped and fill views through common Windows gestures.
- When using another app in fill view and launching Firefox, the application started in fill view.
- Firefox switched between snapped and fill views as expected with the common gestures.
Status: RESOLVED → VERIFIED
Whiteboard: feature=story c=Browser_views u=metro_firefox_user p=0 status=for_testing → feature=story c=Browser_views u=metro_firefox_user p=0 status=verified
Blocks: metrov1it0
No longer blocks: metrov1legacy
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: unspecified → ---
Blocks: metrov1planning
No longer blocks: metrov1it0
Flags: needinfo?(mbrubeck)
Whiteboard: feature=story c=Browser_views u=metro_firefox_user p=0 status=verified → feature=story c=Browser_views u=metro_firefox_user p=0
Blocks: metrov1it0
No longer blocks: metrov1planning
Whiteboard: feature=story c=Browser_views u=metro_firefox_user p=0 → feature=story c=Browser_views u=metro_firefox_user p=3 status=verified
Whiteboard: feature=story c=Browser_views u=metro_firefox_user p=3 status=verified → feature=story c=Browser_views u=metro_firefox_user p=3
Flags: needinfo?(mbrubeck)
Blocks: metrov1backlog
No longer blocks: metrov1it0
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Blocks: metrov1it6
No longer blocks: metrov1backlog
QA Contact: jbecerra
Status: REOPENED → ASSIGNED
all the work bugs have closed
Status: ASSIGNED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
For Raymond to test and verify.
Flags: needinfo?(mozbugs.retornam)
verified fixed

I'm able to put firefox into snapped view 
Built from http://hg.mozilla.org/mozilla-central/rev/3ada6a2fd0c6 ( 2013-04-18)
Status: RESOLVED → VERIFIED
Flags: needinfo?(mozbugs.retornam)
Depends on: 867115
Depends on: 872944
Verified using http://hg.mozilla.org/mozilla-central/rev/97aa3da59001

Snapped view worked fine both in 1/3 and 2/3 views. Switching between the views worked fine too. 

The tab bar does not show on top, I can't switch tabs in snapped mode, is this by design?
Flags: needinfo?
Flags: needinfo?
This is as designed. We do not want a tab strip in the snapped view.
Depends on: 881837
Ran into a couple of problems for it8 testing using today's nightly, see bug 881837.
Depends on: 877225
User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:25.0) Gecko/20130707 Firefox/25.0
Build ID: 20130707031138

WFM for iteration-9
Tested on Windows 8.1 preview using latest nightly build from ftp://ftp.mozilla.org/pub/firefox/nightly/2013/07/2013-07-07-03-11-38-mozilla-central/
I used same steps given in user story.
I am getting expected result.
Depends on: 898547
Depends on: 913229
No longer depends on: 881837
OS: Windows 8 Metro → Windows 8.1
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.