Story - Use the Auto-Complete Screen

RESOLVED FIXED

Status

defect
P1
normal
RESOLVED FIXED
6 years ago
5 months ago

People

(Reporter: asa, Assigned: rsilveira)

Tracking

Details

(Whiteboard: [block28] feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=8)

Attachments

(2 attachments, 1 obsolete attachment)

Reporter

Description

6 years ago
Posted file UC-39 Use the auto-complete screen (obsolete) —
No description provided.
Reporter

Updated

6 years ago
Priority: -- → P2
Reporter

Updated

6 years ago
Whiteboard: c=navigation_app_bar_and_autocomplete u= p= → c=navigation_app_bar_and_autocomplete u=metro_firefox_user p=
Assignee: nobody → netzen
Whiteboard: c=navigation_app_bar_and_autocomplete u=metro_firefox_user p= → c=navigation_app_bar_and_autocomplete u=metro_firefox_user p=2
Assignee: netzen → nobody
Blocks: 823990
Whiteboard: c=navigation_app_bar_and_autocomplete u=metro_firefox_user p=2 → c=navigation_app_bar_and_autocomplete u=metro_firefox_user p=
Blocks: 831532
Assignee: nobody → netzen
Assignee: netzen → nobody
OS: Windows 8 → Windows 8 Metro
Summary: Use the auto-complete screen → Story - Use the Auto-Complete Screen
Whiteboard: c=navigation_app_bar_and_autocomplete u=metro_firefox_user p= → feature=story status=on_hold c=navigation_app_bar_autocomplete u=metro_firefox_user p=0
Priority: P2 → P5
Reporter

Updated

6 years ago
Depends on: 784042
Reporter

Updated

6 years ago
No longer blocks: 823990
Priority: P5 → P4
Depends on: 837396
No longer blocks: 831532
Depends on: 831532
Depends on: 836129
No longer depends on: 836129
Depends on: 836129
Whiteboard: feature=story status=on_hold c=navigation_app_bar_autocomplete u=metro_firefox_user p=0 → feature=story status=on_hold c=navigation_app_bar_autocomplete u=metro_firefox_user p=0 status=on_hold
No longer depends on: 837396
Duplicate of this bug: 782801
Blocks: metrov1onhold
No longer blocks: metrov1backlog
Reporter

Updated

6 years ago
Depends on: 782805
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: unspecified → ---
Reporter

Comment 2

6 years ago
Updated story.
Attachment #703480 - Attachment is obsolete: true
Reporter

Updated

6 years ago
No longer blocks: metrov1onhold
Whiteboard: feature=story status=on_hold c=navigation_app_bar_autocomplete u=metro_firefox_user p=0 status=on_hold → feature=story status=on_hold c=navigation_app_bar_autocomplete u=metro_firefox_user p=0
Whiteboard: feature=story status=on_hold c=navigation_app_bar_autocomplete u=metro_firefox_user p=0 → feature=story status=on_hold c=navigation_app_bar_autocomplete u=metro_firefox_user p=13
This can be reduced to a p=2 if we create a new story which is low priority for bug 784042.
Flags: needinfo?(asa)
New story would have Bug 784042 as its work dependency.
Reporter

Comment 5

6 years ago
That sounds fine to me. Marco, can you create that story bug or do you need me to?
Flags: needinfo?(asa)
Hi Asa, I'll create the shell and move it to 'on hold' where you can review and add details.
No longer depends on: 784042
Whiteboard: feature=story status=on_hold c=navigation_app_bar_autocomplete u=metro_firefox_user p=13 → feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=2
Blocks: metrov1backlog
No longer blocks: metrov1planning
Note, this does not include the snapped view autocomplete work: that is story 833200
Assignee: nobody → ally
Blocks: metrov1it6
No longer blocks: metrov1backlog
Priority: P4 → P2
QA Contact: jbecerra
Status: NEW → ASSIGNED
Blocks: metrov1planning
No longer blocks: metrov1it6
Frank, Stephen, and I agreed upon this solution (please see attached pdf).
 
The behaviors: 
Tapping on URL field triggers a search app bar which only contains a search field, a Close button. (Start Page will not be shown in this case)

When the user starts typing, results show up on a semi-transparent in-context auto-complete page.

To exit, tap the “Close” button on the bottom right.

Still awaiting for feedback from Asa. But I will start prototyping transitions anyway.
Priority: P2 → P1
Blocks: metrov1backlog
No longer blocks: metrov1planning
Reporter

Updated

6 years ago
Depends on: 855691
:mbrubeck has requested this one as his start bugs touch this heavily.
Assignee: ally → mbrubeck
Blocks: metrov1it7
No longer blocks: metrov1backlog
(In reply to Yuan Wang(:Yuan) – Firefox UX Team from comment #8)
> When the user starts typing, results show up on a semi-transparent
> in-context auto-complete page.

Any particular requests for the autocomplete results in snapped mode?  Should they be half-height like the new full view, or full-height like they are now?
Flags: needinfo?(ywang)
(In reply to Matt Brubeck (:mbrubeck) from comment #10)
> (In reply to Yuan Wang(:Yuan) – Firefox UX Team from comment #8)
> > When the user starts typing, results show up on a semi-transparent
> > in-context auto-complete page.
> 
> Any particular requests for the autocomplete results in snapped mode? 
> Should they be half-height like the new full view, or full-height like they
> are now?

I think it makes more sense to have the snap view auto-complete half-height like the new full view. So when the users change Firefox from full to snap view(or vice versa), the transitions will feel natural. Also, half-height screen is friendly for soft keyboard users. 

The only question is if we can display 9 search result tiles, and 6 small search engine tiles. If not, we will need to cut the number of search results.

Stephen, could you play around with the new tiles (probably smaller version) and see how well they can fit in the half-height snap view? Thanks!
Flags: needinfo?(ywang) → needinfo?(shorlander)
Here are some explorations around this: http://people.mozilla.com/~shorlander/files/design-specs-metro/metro-designSpecs-awesomeResults-splitView.html

If we want to use a partial overlay then the tiles will have to be pretty small and the search options will be cut off with the onscreen keyboard.

We can show fewer results and scroll the search engines or we can use a full width/height overlay and show larger tiles and scroll all of it for onscreen keyboard use.
Flags: needinfo?(shorlander)
(In reply to Stephen Horlander from comment #12)
> Here are some explorations around this:
> http://people.mozilla.com/~shorlander/files/design-specs-metro/metro-
> designSpecs-awesomeResults-splitView.html
> 
> If we want to use a partial overlay then the tiles will have to be pretty
> small and the search options will be cut off with the onscreen keyboard.
> 
> We can show fewer results and scroll the search engines or we can use a full
> width/height overlay and show larger tiles and scroll all of it for onscreen
> keyboard use.

Thank you, Stephen. Those explorations are great. 
Seems like we have to cut the title and URLs if we want to use smaller tiles on partial overlay. That makes it difficult to recognize those tiles. Having a vertical scroll bar on half-screen overlay feels heavy

Being able to identify tiles are more important than consistency here. So I personally think we should go for having larger tiles on full height overlay, and enable vertical scrolling when onscreen keyboard is in use. 

Other thoughts?
Blocks: metrov1it8
No longer blocks: metrov1it7
Marco, since the UX has changed here from the design that jwilde had implemented, I'd like to change the point estimate to p=5.
Flags: needinfo?(mmucci)
Done.  Thanks Matt.
Flags: needinfo?(mmucci)
Whiteboard: feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=2 → feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=5
Reporter

Updated

6 years ago
No longer blocks: metrov1it8
Assignee: mbrubeck → nobody
Depends on: 883390
Assignee: nobody → jwilde
Blocks: metrov1it10
No longer blocks: metrov1backlog
Whiteboard: feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=5 → feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=8
Depends on: 887138
Depends on: 891133
Depends on: 892240
Depends on: 892241
Blocks: metrov1it11
No longer blocks: metrov1it10
Depends on: 894715
Depends on: 894811
Depends on: 895520
Assignee: jwilde → nobody
Blocks: metrov1backlog
No longer blocks: metrov1it11
QA Contact: jbecerra
Status: ASSIGNED → NEW
Reporter

Updated

6 years ago
Depends on: 897113
Reporter

Updated

6 years ago
Depends on: 897198
Whiteboard: feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=8 → [Metro Preview] feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=8
Summary: Story - Use the Auto-Complete Screen → [MP] Story - Use the Auto-Complete Screen
Depends on: 891667
Blocks: 903287
No longer blocks: 903287
Depends on: 903287
Blocks: 903292
Depends on: 903294
No longer blocks: 903292
Depends on: 903292

Updated

6 years ago
Depends on: 898106
Depends on: 903687
Depends on: 904417
Depends on: 904427
Depends on: 904493
Whiteboard: [Metro Preview] feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=8 → [preview] feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=8
Assignee: nobody → rsilveira
Blocks: metrov1it14
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
QA Contact: jbecerra
Blocks: metrov1it15
No longer blocks: metrov1it14
Depends on: 916383
Blocks: metrov1it16
No longer blocks: MetroPreviewRelease, metrov1it15
Summary: [MP] Story - Use the Auto-Complete Screen → Story - Use the Auto-Complete Screen
Whiteboard: [preview] feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=8 → feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=8
Blocks: metrov1it17
No longer blocks: metrov1it16
No longer depends on: 895520
No longer depends on: 903292
Blocks: metrov1it18
No longer blocks: metrov1it17
Whiteboard: feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=8 → [block28] feature=story c=navigation_app_bar_autocomplete u=metro_firefox_user p=8
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
Build ID: 20131117030203

Covered the user story and ran through all of its scenarios without any issues using metro full view.

The only thing I would like to mention here is the close button (X). I think it's too bright, it can be quite difficult to spot it.


This also needs device verification.
Bug # 904998 was created to address the issue Cornel mentioned above regarding the "X" being too bright under the auto-complete window.
OS: Windows 8 Metro → Windows 8.1

Updated

5 months ago
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.