update html5shiv.js to include <main>

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: icaaq, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20130117 Firefox/21.0
Build ID: 20130117030933

Steps to reproduce:

the current html5shiv does not include the new element <main>



Expected results:

Update the shiv to the one where the main element exists. https://github.com/aFarkas/html5shiv
Hi Isac-

Could you give us a little more background about why this is important?

Thanks,
Jen
Flags: needinfo?(icaaaq)
(Reporter)

Comment 2

6 years ago
Hi Jen, 
the new <main> element is being implemented in firefox https://bugzilla.mozilla.org/show_bug.cgi?id=820508 and webkit https://bugs.webkit.org/show_bug.cgi?id=103172 and it has been added to the html5shiv[1][2] so that developers can style and use <main> in Internet Explorer as well.

You should just update the existing html5shiv https://github.com/mozilla/bedrock/blob/master/media/js/libs/html5shiv.js to the one that has <main> support.

After that bedrock can use <main> :)

[1] https://github.com/aFarkas/html5shiv/commit/a6a89bdd4b39656450411d608198c790384e5e96
[2] https://github.com/aFarkas/html5shiv/issues/81
Flags: needinfo?(icaaaq)
Firefox nightly now supports <main>.
(Reporter)

Comment 4

6 years ago
PR added https://github.com/mozilla/bedrock/pull/617
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
cc+ Steve Faulkner since he'll likely be happy to see this :)
(Reporter)

Comment 6

6 years ago
The new downloadpage has the new main-element implemented :)

http://www.mozilla.org/en-US/firefox/new/
You need to log in before you can comment on or make changes to this bug.