Closed Bug 831999 Opened 12 years ago Closed 11 years ago

Don't show 'Payment failed. Try again later' error when user cancels a purchase

Categories

(Marketplace Graveyard :: Payments/Refunds, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED
2013-06-06

People

(Reporter: krupa.mozbugs, Assigned: scolville)

References

Details

Attachments

(2 files)

steps to reproduce:
1. Launch marketplace-dev app on your unagi phone
2. Search for a paid app like 'Private yacht'
3. Log in and Click on the purchase button
4. PaymentFlow opens in a trustedUI
5. Cancel the purchase flow

expected behavior:
User returns to the marketplace-dev app

observed behavior:
User returns to the marketplace-dev app and there is an error- "payment failed. Please try again later"

We shouldn't show error messages when user deliberately cancels the purchase.
I can't get that far, i'm impressed.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
This bug is still happening. STR from comment 0 are still valid.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attached image screenshot
This should now have a notification specific to the payment process having been cancelled.
Status: REOPENED → ASSIGNED
Assignee: nobody → scolville
This is blocked by an issue in persona caused by the oncancel handler not being fired when the user clicks cancel jedp is going to look into that.
I filed this issue to track the persona oncancel bug:

https://github.com/mozilla/browserid/issues/3456
Priority: -- → P3
https://github.com/mozilla/fireplace/commit/a2e58161f6b8d8af4f83b98977720e8d489de4b1
Status: ASSIGNED → RESOLVED
Closed: 12 years ago11 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-06-06
verified fixed
Status: RESOLVED → VERIFIED
Attached image post-fix screenshot
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: