Last Comment Bug 832057 - Cannot make payments with unconfirmed PIN
: Cannot make payments with unconfirmed PIN
Status: VERIFIED FIXED
:
Product: Marketplace
Classification: Server Software
Component: Payments/Refunds (show other bugs)
: 1.0
: x86 Mac OS X
: P1 normal (vote)
: 2013-01-24
Assigned To: Wraithan (Chris McDonald) [:wraithan]
:
Mentors:
Depends on:
Blocks: marketplace-payments
  Show dependency treegraph
 
Reported: 2013-01-17 15:21 PST by Kumar McMillan [:kumar] (needinfo all the things)
Modified: 2013-06-09 21:51 PDT (History)
1 user (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Kumar McMillan [:kumar] (needinfo all the things) 2013-01-17 15:21:43 PST
STR:
- sign into Marketplace as a new Persona user
- purchase Private Yacht
- when webpay prompts you to create a pin, create one
- when webpay says Confirm PIN, click the X to close the payment window and return to Marketplace
- purchase Private Yacht again

Expected: webpay should pick up where it left off and ask you to create and confirm a PIN

Actual: webpay asks you to enter a PIN and then says "PIN does not match" because it's not actually set.
Comment 1 Kumar McMillan [:kumar] (needinfo all the things) 2013-01-17 15:43:10 PST
This was fixed when the auth decorator landed. Nice!
Comment 2 Kumar McMillan [:kumar] (needinfo all the things) 2013-01-17 15:46:43 PST
Whoops, spoke too soon. With the STR above, the buyer is asked to confirm her PIN on every purchase repeatedly. She should only have to confirm it once.
Comment 3 Kumar McMillan [:kumar] (needinfo all the things) 2013-01-18 11:41:32 PST
The STR are working for me now. Thanks. I think some solitude changes went in to fix it.
Comment 4 krupa raj[:krupa] 2013-06-09 21:51:41 PDT
This was fixed in bug 861423

Note You need to log in before you can comment on or make changes to this bug.