Last Comment Bug 832066 - Remove deprecated NS_IMPL_CYCLE_COLLECTION_CLASS from nsMsgRDFDataSource.cpp
: Remove deprecated NS_IMPL_CYCLE_COLLECTION_CLASS from nsMsgRDFDataSource.cpp
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Database (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: Thunderbird 21.0
Assigned To: Mike Conley (:mconley)
:
:
Mentors:
: 832134 (view as bug list)
Depends on:
Blocks: 822289
  Show dependency treegraph
 
Reported: 2013-01-17 15:40 PST by Mike Conley (:mconley)
Modified: 2013-01-18 08:46 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix (754 bytes, patch)
2013-01-17 15:43 PST, Mike Conley (:mconley)
no flags Details | Diff | Splinter Review

Description Mike Conley (:mconley) 2013-01-17 15:40:45 PST
Bug 822289 eliminated the NS_IMPL_CYCLE_COLLECTION_CLASS macro, thus busting our builds, which call that macro.

According to the patch in bug 822289, the correct thing to do is to simply remove the macro - it appears to no longer be necessary.
Comment 1 Mike Conley (:mconley) 2013-01-17 15:43:02 PST
Created attachment 703641 [details] [diff] [review]
Fix

I've confirmed that this fixes my local build. Landing with r=bustage-fix.
Comment 2 Mike Conley (:mconley) 2013-01-17 15:45:03 PST
Landed on comm-central as https://hg.mozilla.org/comm-central/rev/393bcf57ae31
Comment 3 Joe Sabash [:JoeS1] 2013-01-18 08:46:21 PST
*** Bug 832134 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.