Don't report CSS errors in production builds r=cjones

RESOLVED FIXED in Firefox 21

Status

Firefox OS
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: fabrice, Assigned: fabrice)

Tracking

unspecified
B2G C4 (2jan on)
All
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, firefox19 wontfix, firefox20 wontfix, firefox21 fixed, b2g18+ fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Created attachment 703687 [details] [diff] [review]
patch

mfinkle reports a 9% improvement in Tp4 on fennec with that change. I only turned it on in prod builds so gaia developers can still get their error logs :)
Attachment #703687 - Flags: review?(jones.chris.g)
(Assignee)

Updated

5 years ago
blocking-b2g: --- → tef?
(Assignee)

Updated

5 years ago
Assignee: nobody → fabrice
Attachment #703687 - Flags: review?(jones.chris.g) → review+
Comment on attachment 703687 [details] [diff] [review]
patch

Actually, can we make this a setting enabled along with the current logging setting in the gaia UI?  We want developers to see these.
Attachment #703687 - Flags: review+
(Assignee)

Comment 2

5 years ago
Created attachment 703710 [details] [diff] [review]
patch v2

Yep, that makes sense!
Attachment #703687 - Attachment is obsolete: true
Attachment #703710 - Flags: review?(jones.chris.g)
Comment on attachment 703710 [details] [diff] [review]
patch v2

<3
Attachment #703710 - Flags: review?(jones.chris.g) → review+
Wouldn't block on this but a trivial pref change that's been validated on fennec to be a 10% load-time improvement is something I would approve in a heartbeat.
blocking-b2g: tef? → -
tracking-b2g18: --- → +
(Assignee)

Comment 6

5 years ago
Comment on attachment 703710 [details] [diff] [review]
patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: we won't get a 10% page load win
Testing completed: 
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none
Attachment #703710 - Flags: approval-mozilla-b2g18?

Comment 7

5 years ago
Comment on attachment 703710 [details] [diff] [review]
patch v2

Approving for v1.0.0 (mozilla-b2g18 tip) given the risk/reward here.
Attachment #703710 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/releases/mozilla-b2g18/rev/8dbc4068419a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-b2g18: --- → fixed
status-firefox19: --- → wontfix
status-firefox20: --- → wontfix
status-firefox21: --- → fixed
Target Milestone: --- → B2G C4 (2jan on)
You need to log in before you can comment on or make changes to this bug.