Fail to open new window on a link with target=_blank

RESOLVED DUPLICATE of bug 82790

Status

--
major
RESOLVED DUPLICATE of bug 82790
18 years ago
13 years ago

People

(Reporter: volpe, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
When I click on any link that has target=_blank specified, no new window is
opened. In fact, nothing happens at all within the GUI. This also happens when
target=some_string and some_string doesn't refer to another frame. Also, when
the link is clicked, mozilla pegs the CPU for a few seconds and then prints
"Document http://... loaded successfully" on stdout... but the new window
doesn't appear!

This happened, ironically, with the bugzilla helper form.

Reproduce:
1. Load the specified URL
2. Left click on one of the first two links

Actual results:
CPU is pegged for several seconds and then "Document
http://bugzilla.mozilla.org/ loaded successfully" is printed in the terminal

Expected results:
http://bugzilla.mozilla.org/ should be opened in a new window, after the CPU is
pegged of course :-)

Workaround:
Click with middle button and the new window opens as expected (but the referring
site isn't sent; this is documented in another bug)

History:
This has happened with all nightlies I've gotten within the last two weeks or so
(Reporter)

Comment 1

18 years ago
Additional information:
This also happened when I cleared out ~/.mozilla
The page also seems to be loaded over the network, even when it is not displayed

Comment 2

18 years ago
Works fine in Windows BTW. (2001052720)
(Assignee)

Comment 3

18 years ago
confirmed.  this is already reported though.  i will try to find the original
tomorrow if no one has it sooner.

Comment 4

18 years ago
I have the same problem.  I can't search bugzilla with mozilla.  Eventhough a
new window doesn't appear when clicking a link with target=_blank, the "Tasks"
menu includes the new window in the list of open windows.

Comment 5

18 years ago
Dup of Bug 82790? 82790 has a comment that mentions that creating a new profile
may help duplicate it.

Works for me with Linux 2001052908 with an old profile.
Mark, are you still seeing this with a May 30 or newer build?
(Reporter)

Comment 7

18 years ago
Boris - Works great for me on a newer build! (2001053021)
Marking duplicate based on comments.

*** This bug has been marked as a duplicate of 82790 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.