[OTA update] Update fails because verification fails

RESOLVED DUPLICATE of bug 831701

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 831701
5 years ago
5 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(firefox18-)

Details

Attachments

(1 attachment)

Comment hidden (empty)
## Environment :
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/0a7c51803227
Gaia   3c84fa2b74b3dbe591f0d4fbedbac9aac5ca4654
BuildID 20130116070204
Version 18.0
Unagi

## Repro :
1. download the 1/16th build and flash 
2. try to update with the 1/17th build

## Expected :
1. updates

## Actual :
1. fails due to the hash not matching.

## Note :
1. Do we have to have 2 bugs for this?  One for the build to fix the issue and one for code to handle bad builds?  Perhaps another bug to handle null file handling as well...
01-17 22:04:12.342: I/Gecko(107): *** AUS:SVC Downloader:_verifyDownload downloaded size == expected size.
01-17 22:04:12.342: E/GeckoConsole(107): AUS:SVC Downloader:_verifyDownload downloaded size == expected size.
01-17 22:04:25.435: I/Gecko(107): *** AUS:SVC Downloader:_verifyDownload hashes do not match. 
01-17 22:04:25.435: E/GeckoConsole(107): AUS:SVC Downloader:_verifyDownload hashes do not match. 
01-17 22:04:25.435: I/Gecko(107): *** AUS:SVC Downloader:onStopRequest - download verification failed
01-17 22:04:25.435: E/GeckoConsole(107): AUS:SVC Downloader:onStopRequest - download verification failed
01-17 22:04:25.445: I/Gecko(107): *** AUS:SVC getStatusTextFromCode - transfer error: The integrity of the update could not be verified, code: verification_failed
01-17 22:04:25.445: E/GeckoConsole(107): AUS:SVC getStatusTextFromCode - transfer error: The integrity of the update could not be verified, code: verification_failed
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
blocking-b2g: --- → tef?
tracking-firefox18: --- → ?
Dave, can you dupe this to the other bug in this area?
Flags: needinfo?(dhylands)
I'll dup this to 831701. The other related bug is bug 830462 which will fix some, but not all of the hash verification failures.

All of the hash verification failures that I've looked at in detail have been caused by the code appending data from a newer update.mar to the end of some older update.mar.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(dhylands)
Resolution: --- → DUPLICATE
Duplicate of bug: 831072

Comment 6

5 years ago
Bug 831072 is not the bug you're looking for
Duplicate of bug: 831071
Nor is bug 831071 :P
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 831701
(In reply to Chris Lonnen :lonnen from comment #6)
> Bug 831072 is not the bug you're looking for
> 
> *** This bug has been marked as a duplicate of bug 831071 ***

Thanks - apparently I can't type.
blocking-b2g: tef? → ---

Updated

5 years ago
tracking-firefox18: ? → -
Man.  All the dup happy people.  ;p
You need to log in before you can comment on or make changes to this bug.