[CLOCK] Alarm is not ringing after snoozing the first time

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: carlosmartinez, Assigned: iliu)

Tracking

unspecified
x86_64
Windows 7

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.0 fixed)

Details

Attachments

(1 attachment)

Tested in unagi with Gecko-c893ed7.Gaia-d381947.

STR:
1-Open clock app
2-Set alarm 
3-Wait for the alarm to ring once
4-Snooze it
5-Wait for the alarm to ring again

Expected result --> It should ring after five minutes by default
Actual result --> The screen is shown after five minutes as it´s ringing but not sound is played
blocking-b2g: --- → tef?
tracking-b2g18: --- → ?
Assignee: nobody → iliu
blocking-b2g: tef? → tef+
tracking-b2g18: ? → ---
I can reproduce it when alarm goes off sometimes... The root cause is the timing of checking 'document.mozHidden' to start alarm notification. It looks like the localized event coming more early than before. So, we get the value true of 'document.mozHidden' to set a silent alarm.

I can have a quickly fixing by setTimeout with zero delay time(previous solution). But we still need to have a test it meticulously.
Created attachment 704420 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7697

Pointer to Github pull-request
Comment on attachment 704420 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7697

Tim,
We still need a delay time to check the mozHidden. It's the previous solution. Could you please review the pr?
Thank you.
Attachment #704420 - Flags: review?(timdream)
Attachment #704420 - Flags: review?(timdream) → review+
Since the pr is merged(https://github.com/mozilla-b2g/gaia/pull/7697), we can close the issue now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
QA Contact: jshih → fyen
Gaia:     6c53dfd2e5d60393f6a57e9e1a4b5af6a3d6a783
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/2226f181c8c2
BuildID   20130126070202
Version   18.0

Verified.
Status: RESOLVED → VERIFIED
Landed on mozilla-b2g18/gaia master prior to the 1/25 branching to mozilla-b2g18_v1_0_0/v1.0.0, updating status-b2g-v1.0.0 to fixed.
status-b2g18-v1.0.0: --- → fixed
You need to log in before you can comment on or make changes to this bug.