bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Blank context menu items (Android 2.3.x)

VERIFIED FIXED in Firefox 21

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: wesj)

Tracking

({regression, reproducible})

Trunk
Firefox 21
ARM
Android
regression, reproducible
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox21 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 703913 [details]
Nightly (01/18) - Screenshot

See screenshot
(Reporter)

Updated

6 years ago
Assignee: nobody → wjohnston
(Reporter)

Updated

6 years ago
Duplicate of this bug: 832817
(Reporter)

Updated

6 years ago
tracking-fennec: --- → ?
status-firefox21: --- → affected
(Assignee)

Comment 3

6 years ago
This is from bug 829198.

I'm sick of chasing these listview color problems. I'm going to flip us to Holo_light and fixup all the problems that causes.
(Assignee)

Comment 4

6 years ago
Created attachment 705138 [details] [diff] [review]
Patch v1

Moves us to using a light theme throughout. There are a few pieces to this, and it will need bake time...

1.) Doorhangers are using android.R.attr.textColorPrimary even though we have a custom backgrond behind them. This is an easy fix. We shouldn't be using system colors in this case. Autocomplete items have the same problem (custom background using system text colors). I removed both.

2.) The site settings dialog uses custom everything. I made the rows inherit from our normal listitem style so that they have the correct textColor. They override the style's textAppearance to alter their size. This also brought out some bugs in this dialog using v14+ colors and text sizes. I just reverted them to use item height support on earlier versions of Android. Looks fine.

3.) Site settings dialog titlebar. These dialogs aren't actually "light" on pre GB, but for some reason they use a light titlebar text color (black on black?). I can't find a great fix for this (their are system styles but they don't specify a textColor), so I hard coded two different colors (white for pre GB and holo_blue for post).
Attachment #705138 - Flags: review?
(Reporter)

Comment 5

6 years ago
Reviewer?
(Assignee)

Updated

6 years ago
Attachment #705138 - Flags: review? → review?(sriram)
Comment on attachment 705138 [details] [diff] [review]
Patch v1

Review of attachment 705138 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. I couldn't see any possible regressions as all the textColorPrimary's are replaced with a solid color. Please watch out for any regression that might come up.
Attachment #705138 - Flags: review?(sriram) → review+
(Reporter)

Updated

6 years ago
Duplicate of this bug: 833804
https://hg.mozilla.org/mozilla-central/rev/c53380aff1d6
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21

Updated

6 years ago
status-firefox21: affected → fixed

Comment 10

6 years ago
Verified fixed on Samsung Galaxy R (Android 2.3.4)/ Nightly 21.0a1(2013-01-27)
Status: RESOLVED → VERIFIED

Updated

6 years ago
status-firefox21: fixed → verified

Comment 11

6 years ago
Fixed on Huawei U8651 (T-Mobile Prism) Android 2.3.6 Nightly 21.0a1 (2013-01-27). This is an ARMv6 device.
(Reporter)

Updated

6 years ago
Depends on: 836356
(Reporter)

Updated

6 years ago
Depends on: 840267

Updated

6 years ago
Blocks: 815092
tracking-fennec: ? → ---
Depends on: 844834
(Reporter)

Updated

5 years ago
Depends on: 856572
You need to log in before you can comment on or make changes to this bug.