desktop builds contain English text snippets for non-English locale strings

VERIFIED INCOMPLETE

Status

Firefox OS
GonkIntegration
VERIFIED INCOMPLETE
5 years ago
4 years ago

People

(Reporter: aryx, Unassigned)

Tracking

({l12y})

Firefox Tracking Flags

(Not tracked)

Details

Desktop builds contain English text snippets for non-English locale strings.

1. I downloaded the latest b2g-beta Windows desktop emulator build, should be https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/2013-01-18-07-02-01-mozilla-b2g18/b2g-18.0.multi.win32-localizer.zip (I downloaded it from the latest-mozilla-b2g folder).

2. Then go to gaia\profile\webapps\system.gaiamobile.org open the application.zip and go to line 849 which holds all the locales.

3. Search for |"de":| ("de" is the local code for German).

4. Scroll to the right and you will see English texts like
"close":{"textContent":"Close"},"airplaneMode":{"textContent":"Airplane mode"}
despite the German translation being complete (and containing German texts).
I don't have a windows machine to verify whether this is still happening, but I'm sure that a lot of changes around l10n have landed since this was reported.  Please refile in the releng product if you can reproduce this issue.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
The German strings are now in the emulator. Anyway, it doesn't on Windows (bug 832396).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.